Old laptop hdd wont function as external

Closed
Nautic - Oct 5, 2011 at 02:45 PM
megamikeridge
Posts
4
Registration date
Wednesday October 5, 2011
Status
Member
Last seen
October 12, 2011
- Oct 5, 2011 at 03:52 PM
Hi all

I just discarded a few old laptops, all containing 2.5 sata hdds.

Therefor i bought a few enclosures for them to make external hdds with them. But i've got a problem with one of the hdds. Its a WD 160gb "WD 1600B EVS - 22RSTO"

Its functioning just fine as internal hdd in both my old laptops and in my ps3 (tried that for formatting), but no matter which enclosure i put it in to plug it to my pc, it wont run. It's making like a short spinning noise (like it starts running) every 2sec or so, and in between its all quiet. (theres a 2headed usb cable with it, so shouldnt be a problem with power?). My pc wont find or reconize it in any way.. The enclosures are working fine with my other hdds and the hdd is working fine as internal.

Any suggestions is embraced with open arms! :D thank you!

1 reply

megamikeridge
Posts
4
Registration date
Wednesday October 5, 2011
Status
Member
Last seen
October 12, 2011

Oct 5, 2011 at 03:52 PM
Thats a good one @Nautic. That WD is a solid hdd. What brand is the enclosure? Perhaps its not the hdd, but the enclosure itself. We have had clean power incidents in the past with ex hdd enclosures. Have you attempted to try another enclosure from the other hard drives? The ticking sound sounds scary, so we'll leave that conclusion for a rainy day since its still working internally. Try laying the hard drive in a secure position until you find one that eliminates the "spinning noise". Its obviously working when its plugged in via internal.
0