Windows was unable to format the drive [Closed]

Report
-
 Anonymous User -
Hello, I have Windows XP on my dell. I have inserted flash drives into my computer many times before and was able to put data on them with no problem. Then the other day I was trying to put some music on some flash drives of mine and it said I had to format them first. Unfortunately, every time I try to format my flash drives it says "Windows was unable to format the drive."

I tried formatting my flash drives on different computers and it works perfectly fine. I am also able to put files on them. But every time I try putting files on them with my computer it says they need to be formatted.

Please help me figure out what is wrong with my computer!

4 replies


Try this

go to run and type

diskmgmt.msc and click ok

Right click on your USB and select format>>proceed

If that doesnt work use this tool

https://ccm.net/download/download-127-hp-usb-disk-storage-format-tool
Thanks you solved my problem!!!!
Anonymous User
you're welcome
I have done both. Neither of them work

who is your USB manufacturer?
The flash drive manufacturer? One of them is SanDisk and the other is HP. There is nothing wrong with the flash drives though. Its my computer that is having the problem.

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!