Acer aspire 7736z shut off and wont turn on

firefightergrl - Oct 31, 2011 at 09:48 PM
karimmstafa123 Posts 1 Registration date Wednesday January 16, 2013 Status Member Last seen January 16, 2013 - Jan 16, 2013 at 04:50 PM
i have an acer aspire 7736z-4015 laptop running windows 7. after about 15 minutes or so of usage on my laptop this evening, my laptop just shut off. I tried to turn it back on and the back light for the screen came on but the screen was blank and then it would not turn off. I had to remove the battery to shut the screen off. I reinstalled the battery but nothing will come on now. when the charger is plugged in, the light on my laptop does not come on to let you know it is charging but the light on the charger itself is lit up like normal. any help is greatly appreciated.

4 responses

Nov 9, 2011 at 10:09 PM
tried the first suggestion. did not work. I purchased another battery and still nothing. the charging light on my laptop still wont come on. beginning to think it may be a problem with the charger?
Mine just did the same thing!! No low battery warning or anything, it just shut down. Please let me know what you find out.
My Acer 7736 just did the same thing as everyone mentioned above. Any luck finding out what the root problem is. I really don't want to spend a whole lot of money trying to get this thing fixed but it sure would be nice to get all my files off the hard drive before I junk it...
exactly the same issue, turned itself off twice, both times I removed the battery, allow any charge to dispate then powered back up. Third time not so lucky, no lights, no response. tried different charger to no avail, removed ram to clean and even replced cmos battery whilst checking internal connections. would seem to indicate that an internal capacitor has gone if not the power socket. if it is the capacitor then sell for parts or take to a proffesional who can work at a componant level. replacment boards are stupidly pricy. damn shame, real nice little runner.
I have no idea how this works, but it did. I detatched the power cable and took out the battery. Tap 3 (well about 6 times) around bottom of the unit. Put the battery back in, connected the cable. Switched it on.......started up perfectly !!!!!!!
Have same problem on Aspire 7736-4412 I can get the power light to come on if I tap at the power point. thinking more like a dc jack messed up. Tried your suggestions no luck! Will turn on for a few seconds but not sure if battery is dead as well.
Anonymous User
Oct 31, 2011 at 11:02 PM
Option 1:

Unplug your power cord,remove battery

Press the power button for a minute and plug in the ac cord and try starting the PC

If that works,shutdown and reinsert your battery

Option 2:

Try to clean your RAM and reinsert your it properly
This worked thanks
karimmstafa123 Posts 1 Registration date Wednesday January 16, 2013 Status Member Last seen January 16, 2013
Jan 16, 2013 at 04:50 PM
i had the same problem and I pluged out the hdd (hard drive) I tryed to turn on my pc and it works but there is no system (win7) bcz there is no hdd soo I pluged in the hdd again and it really works 100% I hop that it works for u toooo :p saaallllaaaaam :)
May 18, 2012 at 02:43 PM
Exact same model, exact same problem. None of the above options worked, has anybody had any better luck with any other troubleshoots???
You all have dead motherboards, Buy and Acer you get what you buy.
I think Junker's right. Dead motherboard.
Ok I tried all the above mentioned and nothing worked. So I tore the entire laptop down hoping to find a power supply board that could just be replaced. no luck the power supply is integrated onto the mother board itself . What we have here is a case of failed mother boards and a replacement will cost 350. new or around 175-200 used and on ebay. Dont know about anyone else but its just not worth it! A new laptop can be had for just over 200 and you now will get windows 8