Sfsync02.sys [Solved/Closed]

vista.ultimate.64 214 Posts Sunday October 3, 2010Registration date October 18, 2013 Last seen - Nov 10, 2011 at 05:52 AM - Latest reply:  Cosmin
- Mar 29, 2013 at 04:50 AM
Hello,

Hi, whenever I boot my PC, I get an error message sfsync02.sys is not digitally signed. I can get past this by disabling driver signature enforcement, but is there a way I can get this driver to be signed again?

Thanks.

See more 

11 replies

Best answer
vista.ultimate.64 214 Posts Sunday October 3, 2010Registration date October 18, 2013 Last seen - Nov 16, 2011 at 12:25 PM
4
Thank you
Hi again. I managed to resolve the error so I thought i'd put it up here for others who experience it.

I contacted the company Star Force Technologies.

This is what they repied



"Hello,
In order to solve compatibility issue you can either just update the existing installed in your PC drivers using "sfdrvup.exe" from here:
http://www.star-force.com/support/drivers/ ; Run it and reboot your PC after it.
Or you can uninstall the drivers but if the protected application requires a StarForce driver, this driver will be re-installed as soon as you launch the application again and will need the updating after it.
The following procedure will ensure that all StarForce related components are completely removed from your system.
1. Download the SFREMOVE tool as a ZIP archive: http://www.star-force.com/support/sfdrvrem.zip
2. Extract and store sfdrvrem.exe anywhere on your hard disk.
3. Run sfdrvrem.exe.
Thank you for contacting our support group!"



I removed the driver using http://www.star-force.com/support/sfdrvrem.zip and now the problem is solved.

Thank you, vista.ultimate.64 4

Something to say? Add comment

CCM has helped 1665 users this month

nice share
im sorry to bother,i have the same problem on Windows 7 so I suppose I wont be able to do the same. I just installed a game and added sf_sync02 to the registry and starforce is not even installed so when I try to use the Starforce removal software it doesnt work because , obviously I dont have it installed
Anonymous User - Nov 10, 2011 at 10:43 AM
0
Thank you
Open command prompt as administrator and run this

bcdedit /set loadoptions DDISABLE_INTEGRITY_CHECKS

Restart your PC,this is a old trick,dont know if it works now
vista.ultimate.64 214 Posts Sunday October 3, 2010Registration date October 18, 2013 Last seen - Nov 10, 2011 at 10:47 AM
0
Thank you
OK i'll try this, I'll WB when I'm done. I did do the command

To confirm, there are 2 D's for disable, right?

bcdedit.exe /set nointegritychecks ON

Thanks.
yes
vista.ultimate.64 214 Posts Sunday October 3, 2010Registration date October 18, 2013 Last seen - Nov 10, 2011 at 06:14 PM
0
Thank you
OK, I tried the restart and no luck, still need to disable the driver signature enforcement. Any idea's?
Anonymous User - Nov 10, 2011 at 06:36 PM
0
Thank you
Try this

go to run and type

gpedit.msc and click ok

Go to

User Configuration - Administrative Templates -System -Driver Installation

On the right side you have

Code signing for drivers

Double click >>>select ENABLE option

Go down to OPTIONS

When windows detect a driver without signature

Select IGNORE

and reboot

Let me know if it works
vista.ultimate.64 214 Posts Sunday October 3, 2010Registration date October 18, 2013 Last seen - Nov 12, 2011 at 08:11 AM
0
Thank you
Hi, thanks for the new step, but still no luck.

If I cannot permanently disable the driver signature enforcement, can I get the sfsync02.sys driver signed again?

I believe it's starforce, protection for gaming. So could I delete the file if we cant sign it?
did you check their website for any update?
vista.ultimate.64 214 Posts Sunday October 3, 2010Registration date October 18, 2013 Last seen - Nov 12, 2011 at 01:43 PM
0
Thank you
starforces? no I havent, but I dont know which game installation added this file.