Ipod Nano 4th generation not turning on..

Munk - Mar 2, 2012 at 11:52 AM
 Blocked Profile - Mar 4, 2012 at 12:03 AM
Well, I've had this ipod for a couple months now and it never really gave me problems. The other day, I went to plug it in and it won't charge or turn on, just stays black. The battery was dead when I went to plug it in (E.g, it shut off on me from losing battery). It shows up as an unknown device on my computer when I plug it in and it won't let me install the driver. I've already tried pressing the menu and center buttons down at the same time (I've had to do that before) but it doesn't do anything. I've been searching the web for a while now and I've tried everything, but it just won't work..any ideas?

1 response

Blocked Profile
Mar 4, 2012 at 12:03 AM

Please, bare in mind that Kioskea is a mutual aid community, all answers on the forum are provided by volunteers who give their time free to help solve issues.

Therefore, it is specifically requested from Kioskea forum users correspond showing mutual respect. Therefore, when requesting assistance, the use of polite expressions,as for elsewhere in similar circumstances, is appreciated. (please, thank you, appreciate, grateful, etc.)


Please, copy, modify and repost your message respecting the politeness charter.

We trust that you understand.