DVD Drive Not Working

Closed
mercedes215 Posts 1 Registration date Saturday February 2, 2013 Status Member Last seen February 2, 2013 - Feb 2, 2013 at 07:50 PM
 jen - Mar 6, 2013 at 01:53 AM
Hello,
I have a Toshiba Satellite laptop and as of recently, the disk drive isn't working.
When I put a CD, DVD or Data disk in, it sounds like it's reading it, but nothing shows up. If I go to "My Computer" it doesn't even show my disk drive. Help, please!


2 replies

Zohaib R Posts 2368 Registration date Sunday September 23, 2012 Status Member Last seen December 13, 2018 69
Feb 5, 2013 at 08:26 AM
Hi mercedes215,

Please try the below mentioned steps and check if this helps:

1. Check in the BIOS (System Setup) if the Optical Drive (CD/DVD Drive) is detected and is enabled. For steps on how to get to BIOS and make changes refer to the User's Manual of the Motherboard or the system.
2. If the Optical Drive is not shown in the BIOS, load BIOS defaults (or Optimized Settings).
3. If the Optical Drive is still not detected in the BIOS, reseat the Optical. (Note: Before this step is performed remove any power connections and external devices, safely remove the chassis cover and locate the Optical Drive).
4. If the Optical Drive is still not detected, try a different Optical Drive Data Cable (you can use the one from the Hard Drive, if the cables are same).
5. If there are no results yet, connect the Optical drive to a different port on the motherboard.
6. After performing steps 1 through 5, if the Optical Drive is not detected replace the Optical Drive.
Note: if you are not comfortable opening the computer chassis, take a technician's help.
7. If the Optical Drive is detected in the BIOS but not in Windows, run the below mentioned fix from Microsoft:
https://support.microsoft.com/en-us/help/2970908/how-to-use-microsoft-easy-fix-solutions
8. If the Optical Drive is still not detected in Windows only, update the latest firmware for the Optical Drive. You can find the latest firmware on your computer manufacturer's website, drivers CD or from the Optical Drive manufacturer's website.
9. If still the Optical Drive is not detected in Windows only, Restore your computer to an earlier date (https://support.microsoft.com/en-us/windows?ui=en-US&rs=en-001&ad=US ).
10. If the issue is still not fixed, do an Operating System Reinstallation.

Do reply with results.
0
just clean the lens
0