Pen drive gives error: please insert a disk into removable disk

Solved/Closed
Parkash - Jan 10, 2015 at 07:39 AM
 aditya - Aug 2, 2016 at 10:24 AM
Hello,
I have Sony Vaio USB FLash drive . Whenever I insert the flash drive into the computer, it detects the flash drive and I can see the flash drive icon in the system tray as well as the drive is visible in the windows explorer.However, when I try to open that drive, it gives me the message "Please insert removable disk in to the drive" ,but, the drive is already inserted.

4 replies

Go to diskmgmt.msc
Select ur disk right click-delete volume
Then create new volume
0
BaCkToHaCk
Posts
90
Registration date
Thursday July 30, 2015
Status
Member
Last seen
May 13, 2016
26
Jul 30, 2015 at 09:53 AM
Hi, all
See this subject possible serve you

https://ccm.net/forum/affich-829402-hard-drive-doesn-t-open
-1
suresh kachare
Feb 22, 2016 at 10:22 AM
No sir nothing any proses
0
1. open run
2.type cmpgmnt.msc
3.and run it
4.now click on disk management in left panel
5.now find your disk in bottom and
6.right click on it and click simple volume
7. a new dialog box open
8. just click next and next and net and then finish
9. now your pendrive has been fixed.
-1
it works but what u have written for opening the disk management was wrong but if you will type correct it works very nicely without any error
0
Ambucias
Posts
47366
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
September 1, 2021
11,315
Jan 10, 2015 at 05:07 PM
Hello

No doubt that it has been physically damaged and pen drives cannot be repaired.

Sorry
-2
Hey that's not true, I have the same problem, it's a brand new pen drive, shows in some computers but not mine, "please insert disk into removable disk" is what it says. I've changed and assigned new letters to it but didn't work for me, maybe it might work for you though so follow these steps

1)Go to "run"
2) Type "compmgmt.msc"
3)Click on "Disk Management"
4) Find your drive there and "Right Click" and "Change drive letter and Paths"
5) Click on "Change" and assign it a new letter like Z and click on ok for the pop up
6)It might show on My Computer now or you may have to restart your computer
0
gratefulguy > anonymous
Feb 14, 2016 at 12:56 AM
Thank you so much! This worked for me
0
akash > anonymous
Jul 21, 2016 at 02:36 AM
My disc does not show up there in the removable discs so I m not able to select it to change its name
0
Changing name really worked..
0
Did all the steps then realised all storege is un allocated :) My bad
0