Belkin router isn't working

Closed
Tony - Apr 10, 2015 at 04:02 PM
 Blocked Profile - Dec 14, 2015 at 05:33 PM
Hello, my belkin N300 wireless router isn't working. It will go blue, like it usually does when it is working, but nothing in my house can connect to it. I've tried with my laptop, and all it does is give me a loading sign. I've tried to troubleshoot it, but it doesn't work. I've restarted it, unplugged fifty ways to Monday, and I still can't get it to work. I tried changing my 802. whatever to enabled, and it won't work. I can connect to my internet through an Ethernet cable, but I can't connect to my router. I literally have to connect straight to the wall to get internet.

1 reply

Blocked Profile
Apr 10, 2015 at 08:59 PM
Ok, let us know some stuff before we answer, please:

What OS are you using?
Did it ever work?

Let us know!
0
I am having wierd issues as well. Some sites are blocked. I contaced costumer support they told me to change my parental controls... there are no parental controls lol. After 2 hours of dealing with they literally told me to go get a new one. Wow!
0
Blocked Profile
Aug 24, 2015 at 02:43 PM
OK, well once again, what OS, what router, and did it ever work?
0
My router is doing the same thing, belkin N300 XR. Not sure what OS means...
0
Blocked Profile
Sep 9, 2015 at 07:58 PM
os=Operating System

Did it ever work?
0
Im having the same problem, but its across all my wireless devices. Im able to get on my computer because its hardlined, but everything from my xbox to my phone can't find my router. It did work fine up until about 5 days ago. My OS is Windows vista on this computer but it connects to the internet just fine.
0