Laptop shows blank screen when i turn on [Closed]

Report
-
Posts
2067
Registration date
Thursday October 23, 2014
Status
Member
Last seen
February 28, 2017
-
hello..
when i turn on my dell laptop it shows a blank screen and when i hit the f8 button i only get a beep sound.i have tried shutting down and removing the battery but same problem persists..please help!!!

1 reply

Posts
2067
Registration date
Thursday October 23, 2014
Status
Member
Last seen
February 28, 2017
91
Hello mona,

This beeping sound that you hear might be due to either failing mother board, RAM or hard drive. Depending of your motherboard manufacturer, you can find what this error means.
Can you hear the drive spinning up? If can't then the hard drive has failed and that's the reason for your system not to start up. You could try pulling out the drive and connecting it to another PC via SATA-USB cable to see if it will work there. If you have an external enclosure, you could try with it.
Another option is to test your RAM for failures.

Hope this helps.

KY_WD
Hi I.kinda have the same issue but different. I disassemble.my computer to.replace the jack. But now all I get is a screen with bright light. I.cant hear the fan in my laptop.and my hard drive does not.boot up.nor.makes that.spinning sound.anymore
Posts
3591
Registration date
Friday February 6, 2015
Status
Moderator
Last seen
July 18, 2016
751 > Valentin
Hello valentin,
Your issue might be seen like Power supply in laptop.. which in turn is issue with mother board..
Contact the technician to solve this issue..
In mean time you try this..
1) Remove battery and power
2) press power button for 30 sec
3) Replace battery switch on the laptop..
4) Try to replace the RAM also
Posts
2067
Registration date
Thursday October 23, 2014
Status
Member
Last seen
February 28, 2017
91 > Valentin
Hi from me Valentin,

You should do what Computertech gave as troubleshooting steps. After doing all this, I would recommend that you take out your hard drive and connect it to another PC like I told mona. If it does spin up while connected via SATA-USB adaptor, then the problem is with your motherboard really.

Good luck.

KY_WD