Internet connected on wifi but wired not working.

[Closed]
Report
Posts
2
Registration date
Friday July 24, 2015
Status
Member
Last seen
July 24, 2015
-
 Mike -
Hello,

Well this is embarrassing. First time I've ever had to make an account to ask a question but no amount of googling is saving me from despair.

My iPhone, laptop, Sky and Xbox are all connected to wifi successfully. How do I know? I'm writing this on wifi on my iPhone. So my internet works. But my wired Ethernet PC is having problems. Strangely the Xbox is also wired and yet has no issues.

Internet on my PC is usually connected to "Network 6" in local area connections. But every now and then (once a month or so) it will connect to "Network 7" and stop working. List of things I've tried:

Unplugging Ethernet in PC.
Unplugging every other connection possible and reconnecting.
Reset router.
Hard reset router.
Disable and enable network driver in settings.
Uninstall network driver and reinstall (this worked for about half an hour, then went back to Network 7. After which uninstalling and reinstalling just went back to Network 7)
I've tried messing with the TCP/IPv4 but guides from googling are far too vague to understand.
Roll back driver (again worked briefly then back to Network 7)
Manually installed old driver.
Windows diagnostic test troubleshooting - has this ever done anything for anyone? -_-

I even got desperate and tried to change network setting in BIOS. But I'm using a Sabertooth Z77 and any time I make a change, the PC will fail to boot up and I have to reset the CMOS with the switches directly on the motherboard. I can't boot in safe mode due to the Z77 having its own BIOS screen and like I said any changes result in the PC not booting so I can't even use that, which would probably work.

All I get is DNS server isn't responding. Sometimes it says it's connected to the Internet. But regardless it doesn't work. If anyone could provide an extensive idiot proof step by step guide to the TCP solution I will give that a go. But otherwise I'm completely dumbfounded.

Help.

2 replies

Posts
2
Registration date
Friday July 24, 2015
Status
Member
Last seen
July 24, 2015

Sorry I forgot to add my spec.

Windows 7 - 64
Sabertooth Z77 mobo.
GTX Titan GPU.
Kingston 16GB RAM.
i5-3750K CPU @ 3.4GHz
2 x SSD 240GB
1 x HD 1TB

I've had the PC for 2 and half years. This is the only issue I've had other than a dodgy BIOS.
Any response?