No sound when headphones are plugged in on Windows

Closed
Report
-
 Dano -
Hello,

I've had this problem for a while.
My current laptop is Toshiba Satellite A660-1DW but this problem was also present on Toshiba Satellite C-660 (as far as I can remember, anyway). On Windows (both 7 and 10), the sound plays normally through the speakers but when I plug the headphones in, there's no sound at all. Changing volume doesn't work, booting into the OS with/out the headphones plugged in is the same, the system can't even "see" the headphones - they're not in the sound menu. Using an external USB sound card works, but I'd rather use the integrated card than waste a USB slot and have lower quality sound. (not to mention I lost that card, oops)
I know it's not a hardware or headphones problem because the sound works perfectly fine on Linux.
I have uninstalled and reinstalled the drivers before, etc.
I also uninstalled all the sound drivers and reinstalled Realtek's older drivers (thinking it could be a bad update). That actually worked, so I also disabled automatic updating for that driver... Next time I booted into Windows, the sound was broken again.
It's a real bother considering that there are some nice games I'd love to play with my headphones, on Windows.

Any help would be greatly appreciated!

1 reply

I have the same problem. Windows 10. Realtek audio does not recognize headphones as an option. I downloaded updated drivers and it actually worked - had a microphone tab in Realtek audio controller and got sound. Next time I started my computer it was back to same problem, sound from speakers, headphones not seen. Tried uninstall and redownloading updated drivers but this time - still have same problem