Pen Drive not showing data [Solved/Closed]

Posts
1
Registration date
Thursday September 24, 2015
Last seen
September 24, 2015
- - Latest reply:  ecaina - Jan 8, 2017 at 11:11 AM
My pendrive is having data but it is not showing ?
See more 

2 replies

Best answer
Posts
275
Registration date
Friday October 10, 2014
Status
Certified CCM Contributor
Last seen
October 19, 2016
6
Thank you
Hey there, tparamas.

Just a tip for future reference - you should never have the only copy of your data on a flash drive and you should always have it backed up somewhere as well.
Is the pen drive detected in Windows Explorer (My Computer)? If "Yes", do you get any errors when you try to open it? Is it recognized in Disk Management or Device Manager?
I'd recommend that you try the flash drive with a different computer/device, to see if the same thing happens. You could also try to access it via Ubuntu Live USB/DVD, to see if it's properly recognized and if you can get to your files. Try out some data recovery options as well.

Hope that helps. Please let me know how everything goes.
Boogieman_WD

WD Representative

Say "Thank you" 6

A few words of thanks would be greatly appreciated. Add comment

CCM 2965 users have said thank you to us this month

I have got the issue solved with the command attrib -h -r -s /s /d g:\*.* as suggested by someone else.
Posts
50324
Registration date
Monday February 1, 2010
Last seen
November 22, 2018
5
Thank you
Try this 1

Check if the files are not in hidden mode.

Click on "Start" -->Run --> Type cmd and press Enter.

Here I assume your pendrive drive letter as G:

Enter this command.

attrib -h -r -s /s /d g:\*.* --> Press Enter

You can copy the above command --> Right-click in the Command Prompt and

paste it.

Note : Replace the letter g with your pen drive letter.

Now check your pen drive for the files.

Good Luck
Wonderful. Worked like Magic. Thanks a Million asI had very important data . Hats off to you .
Thanksssssssssss a lot this worked for me too.
right command suggest by ambucian thanks a tone @@@@@
thannks very help full
Superb! Thanks a lot