HDD on SATA 2 undetected by OS

 Guillaume -

I bought a new 1Tb HDD and the BIOS detects it, but the computer management doesn't scan it. I've tried different SATA port and wire, nothing. Do I not have enough PSU for it to run appropriately? 725w sounds overkilled for my specs...

here they are:

Operating System: Windows 10 Home 64-bit (10.0, Build 10586) (10586.th2_release.151121-2308)

BIOS: BIOS Date: 08/24/12 15:39:49 Ver: 07.02
Processor: AMD FX(tm)-6300 Six-Core Processor (6 CPUs), ~3.5GHz
Memory: 12288MB RAM
Available OS Memory: 12270MB RAM
Page File: 1761MB used, 12364MB available
Windows Dir: C:\WINDOWS
DirectX Version: 12
DX Setup Parameters: Not found
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.10586.0000 64bit Unicode

Display Devices
Card name: AMD Radeon R9 200 Series
Manufacturer: Advanced Micro Devices, Inc.
Chip type: AMD Radeon Graphics Processor (0x6810)
DAC type: Internal DAC(400MHz)
Device Type: Full Device
Device Key: Enum\PCI\VEN_1002&DEV_6810&SUBSYS_E271174B&REV_00
Display Memory: 8165 MB
Dedicated Memory: 2030 MB
Shared Memory: 6135 MB
Current Mode: 1360 x 768 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: PHILIPS
Monitor Id: PHL0000
Native Mode: 1360 x 768(p) (60.015Hz)
Output Type: HD15
Driver File Version: 8.17.0010.1429 (English)
Driver Version: 15.300.1025.0
DDI Version: 12

Disk & DVD/CD-ROM Drives
Drive: C:
Free Space: 20.4 GB
Total Space: 228.1 GB
File System: NTFS
Model: KINGSTON SV300S37A240G ATA Device

Drive: D:
Free Space: 0.1 GB
Total Space: 0.3 GB
File System: NTFS
Model: Hitachi HDS721050CLA660 ATA Device

Drive: E:
Free Space: 170.7 GB
Total Space: 476.6 GB
File System: NTFS
Model: Hitachi HDS721050CLA660 ATA Device

I do find another ATA Device on the BIOS and the Device Manager - which is why I'm thinking it might be power related.

1 reply

Registration date
Monday September 1, 2014
Last seen
February 20, 2017
Hi Guillaume,

Does the issue persist? You are correct that in general this could be a power related issue. At least it looks like it, but it seems you have a pretty powerful PSU. If this is a power related issue, the hard drive should be working properly when other hard drive is disconnected. Have you tried that? Could you tell me what happens when you try to access the hard drive? Is it correctly recognized in Disk Management? I strongly recommend you to check the drive on another PC.

Hope this helps

Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2821 users have said thank you to us this month

Hi R2D2,

Thank you for the reply. The problem was that my new HDD was configured as a memory pool in Win. 10 for some reasons... may be because this is my 3rd storage device (...Microsoft). Anyhow, I deleted the pool, restarted, browsed my disk management and there it was.

Everything is working fine now.

Thanks again and happy New Year.