USB mass storage keeps disconnecting

liory - Apr 17, 2009 at 01:27 PM
 Viky - Nov 26, 2009 at 05:34 AM

whenever I plug in my DOK or any mass storage through USB (including mp3) in windows xp it is assigned as a drive. however, after few minutes (while copying or deleting files) windows xp can't read it any more. browsing the folders fails and all other copy/delete operations fail.
sometimes I manage to prolong that period of time by a dos batch that runs in the background (dir *.* /s).

I already called a technician that told me after 2 days in the lab that this didn't happen to him however when it was brought back the problem occured again. he told that this is strange and that he doesn't think this is a hw problem.

OS = XP home edition SP3
DOK = Sandisk + U3
USB ports = 4 on board + 4 on ext. card
printer = HP
KBD + Mouse = PS2

Thank you.

2 responses

I had exactly the same problem and spent a lot of time trying to find an answer before someone provided me with a very simple solution: uninstall the device in device manager (it will probably be showing as "Unknown Device" under the USB Root Hub), turn off the computer and pull the mains cable out from the power supply. Wait for a good thirty seconds, reconnect and turn on the computer. This forces XP to reinstall the original driver when it restarts.

Hope this helps !!
thanks man I tried all kinds of things and for 6 days I tried to get it to work but today I ready this and in 5 minutes I was up and running!!!!!!!
You definitely do not need to pull out power cables. Just rebooting will work :D
unfoldhelp Posts 13 Registration date Tuesday October 14, 2008 Status Member Last seen June 28, 2009 2
Apr 18, 2009 at 09:20 AM
no one may be able to help you there