Pendrive not working

Closed
Report
-
 bhavi -
Hello,

I am using iball 16gb pendrive, its detecting in the system but not showing any space.showing used space 0, free space 0. & not able to format also. Please help me with Suggessions.


Related:

2 replies

Posts
3606
Registration date
Monday September 1, 2014
Status
Member
Last seen
February 20, 2017
151
Hi Bhavi,

Are you trying to format the pendrive using Disk Management? Could you tell me if the drive has a correct file format and a drive letter? I strongly recommend you to check the pendrive on another PC. You could also try the following:
Open Command Prompt and type the commands:
Diskpart
List disk

Is the pendrive listed with its correct capacity?

If you have important information on the device, use a data recovery tool in order to save some information.

Hope this helps

0
Thank you for your reply!

As you asked, I tried with disk management formatting, it doesn't work!

Also, I tried command promt option, its not showing the drive and capacity.
Even while detecting pendrive also its not showing the capacity!

There is nothing important in the pendrive, but I just want to get my pendrive properly working.

Please do revert if you have any other suggesion!
Thank you
0
Posts
3606
Registration date
Monday September 1, 2014
Status
Member
Last seen
February 20, 2017
151
If the drive cannot be formatted in Disk Management and is not responding properly even on another PC, I would recommend you to change it. Even though you may find a way to format it and make it usable again with some utility, it is highly possible that these problems may reappear suddenly, when you have important data stored in the pendrive. If you wish to try saving your device, check this link because there are some more suggestions there:
https://ccm.net/forum/affich-8617-can-t-format-usb-mass-storage-drive

0
Thank you! But it doesn't work! I think better to buy a new one!
0