Removing Write Protection

Closed
Sumaya - Jan 8, 2017 at 09:53 PM
KY_WD
Posts
2054
Registration date
Thursday October 23, 2014
Status
Member
Last seen
February 28, 2017
- Jan 10, 2017 at 03:28 AM
Hello,

I have tried doing it through regedit but when I try creating a new key following all the steps it does not allow me.
I have also tried disk management but am confused about the instructions, please clarify.

2 replies

KY_WD
Posts
2054
Registration date
Thursday October 23, 2014
Status
Member
Last seen
February 28, 2017
119
Updated by KY_WD on 9/01/17 at 12:43 PM
Hello Sumaya,

You have given so little information that it seems quite impossible to orient myself into your problem. What kind of write protection are you talikg about? Are you talking about a pen drive or an external hard drive? I also would like to know if has anything happened to the device prior to the error that you get.
Please come back to the topic to share more information.

Cheers.
Western Digital representative
0
Sorry, I'm not too good with these things, I can just about fix issues through these forum instructions. It is a USB. The only thing I have used it for so far is to store pictures which are not appearing as I saved them. Tbh I don't care much for the pictures, I was trying to clear the space on it but cant seem to delete anything as everything is write protected. I followed the instructions as best I can (start, run, run regedit, right click on LOCAL_MACHINE, create a new key titled #1), but I cant seem to create a new key.

I looked on the comments and someone else, I think, suggested running disk management, but the instructions became confusing as I could not see what they were instructing to right click and delete (partition or something).

Any advice would be greatly appreciated.
0
KY_WD
Posts
2054
Registration date
Thursday October 23, 2014
Status
Member
Last seen
February 28, 2017
119 > sumaya
Updated by KY_WD on 10/01/17 at 03:28 AM
Hi again,

Frankly said, I'm not very familiar with the registry editting too, so I can't give you more hints on this than Ambucias already did. Honestly, I wouldn't go into that area if I'm not sure about what to change and what the impact would be, because I could mess with an registry that could be fatal to the system's operability.
Can you tell me, have you tried using the command prompt menu? If not, please try the following:
1. Open command prompt
2. Type the following:
attrib -s -h -r X:/*.* / s / d
Then hit "Enter" and wait about for some seconds
Be careful! Respect the spaces between words and script. Change the letter X with that has been assigned to the USB device on your PC (that you can see it in My Computer. It can be anything, depends on each computer.)
3. Finally, browse the flash drive and delete the recycle folder and if there is another one called "Autorun" you have to delete that too.

Let me know if that helped, if you tried it.
0
Ambucias
Posts
47363
Registration date
Monday February 1, 2010
Status
Moderator
Last seen
September 1, 2021
11,279
Jan 9, 2017 at 06:28 PM
Perhaps this CCM how-to will help:

https://ccm.net/faq/4214-how-to-disable-write-protection-on-a-usb-key

Good luck
0
Thank you for getting back to me so quickly.
When regedit opens up and I follow LOCAL_MACHINE, I only see the Default on the right side pane, there is no WriteProtection link I can click on to change it's value.

Can you suggest anything else?
0