My HDD can't accept files and deletes what I copy

[Closed]
Report
-
Posts
3606
Registration date
Monday September 1, 2014
Status
Member
Last seen
February 20, 2017
-
Hello,

I bought a brand new WD Elements 1TB Portable HD. But I encountered a problem on the first time i used it.

I copied 3 video folders (with sub folders inside). One contains 156MB, second contains 1GB and the third one contains 30GB. It finished copying but the Third folder doesnt show up. I was worried so I copied it all again, and the same thing happened.

I also tried formatting the HDD and copied the third folder first. It worked. And then I copied the remaining folders again but when I ejects the HDD, the folders delete itself (except the third folder).

I tried copying files again and again. it shows the folder is corrupted sometimes and I'll cmd chkdsk /f E: and it'll delete itself from the drive.

What should I do?

1 reply

Posts
3606
Registration date
Monday September 1, 2014
Status
Member
Last seen
February 20, 2017
152
Hi jdmn,

I am sorry for any inconveniency caused by your WD drive. You have done very good job trying to resolve the issue. I would try using the chkdsk E: /r command from the Command Prompt. Please test the drive on another PC and with another USB cable.
Check the drive’s condition with Data Lifeguard Diagnostic. You can download it from the link below. Unfortunately, a drive can be damaged if not maintained or transported properly before being sold to the customer.
I would suggest you to contact the seller and use the warranty.
http://products.wdc.com/support/kb.ashx?id=6irPsr – Data Lifeguard Diagnostic for Windows.

Hope this helps