Report

Connected to the Internet, says I have access but nothing works

Ask a question kevaarn 1Posts Saturday September 16, 2017Registration date September 16, 2017 Last seen - Last answered on Sep 16, 2017 at 04:37 PM by Ambucias
So I am connected to the router via an ethernet cable connected to an extender, which in itself is connected to the router wirelessly. I am using Windows 7, and the network icon is the one showing you're connected, and it also says I have Internet access. I can, however, not connect to Steam, Twitch or any other programs that require Internet to connect, and every page I try to open in Mozilla times out. I can use the Internet on my phone, which is connected to the extender's connection. This is why I can't pinpoint what caused the problem. I tried switching ports, the cable itself, IP resetting command and IP renewal command. Nothing worked. I am out of clues. Any ideas? Also, excuse my English.
Helpful
+0
plus moins
Click on Start --> In search bar type ncpa.cpl and press "Enter". Right click on your Network icon ---> Select "Properties" ---> scroll down and double click on "Internet Protocol [TCP/IP]", set your "Preferred DNS Server" to 8.8.8.8 (Google) or 4.2.2.4 (OpenDNS)
Leave a comment

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!