Wifi connected but can't open any websites [Solved/Closed]

notit novice 3 Posts Monday February 10, 2014Registration date February 16, 2014 Last seen - Feb 10, 2014 at 01:57 PM - Latest reply:  ali_sayafan
- Mar 24, 2018 at 06:06 AM
Since Friday morning my HP laptop (has windows 7 home premium) can't open any websites. It shows the internet connected on the network (on IPV4). I have rebooted, restarted modem. released and renewed IPconfig, disabled bonjour, to no avail. Ran multiple diagnostics, one of them said "One or more network protocols are missing."

The other part of the problem is when connected through ethernet directly to modem, laptop tells it is unidentified network, the diagnostic identified error as " local area connection does not have a valid IP configuartion."

Please help.
See more 

36 replies

kieferschild 2388 Posts Sunday October 5, 2008Registration dateModeratorStatus April 27, 2018 Last seen - Feb 13, 2014 at 11:30 AM
+9
Helpful
Can you try a ping to the internet.

go to start > run > type cmd and press OK.

type ping www.google.com

do you get a reply?
Was this answer helpful?  
notit novice - Feb 12, 2014 at 11:11 PM
+2
Helpful
did not find windows firewall listed in the services, trying to find still.

guys, appreciate you taking time to suggest solutions.
kieferschild 2388 Posts Sunday October 5, 2008Registration dateModeratorStatus April 27, 2018 Last seen - Feb 27, 2014 at 06:08 PM
+2
Helpful
Sounds like you've managed to screw up some windows configuration. I recommend taking a backup of your data and restoring your laptop back to factory settings.
notit nolvice - Mar 1, 2014 at 10:09 PM
+2
Helpful
I did the restore to a point 8 months back. No effect on the browsing. still as it was. I think something linked to DNS that did not get impacted by restore, puzzled to say the least.
ac3mark 9319 Posts Monday June 3, 2013Registration dateModeratorStatus May 22, 2018 Last seen - Mar 1, 2014 at 10:11 PM
Have you tried 4.2.2.2 for dns yet?
Victoria

Primary Server Name: nsc1.cv.gv.shawcable.net
Primary Server IP: 64.59.160.13
Secondary Server Name: nsc2.cv.gv.shawcable.net
Secondary Server IP: 64.59.160.15

Vancouver

Primary Server Name: nsc1.wh.vc.shawcable.net
Primary Server IP: 64.59.144.16
Secondary Server Name: nsc2.wh.vc.shawcable.net
Secondary Server IP: 64.59.144.17

OR

Primary Server Name: nsc3.wh.vc.shawcable.net
Primary Server IP: 64.59.144.18
Secondary Server Name: nsc4.wh.vc.shawcable.net
Secondary Server IP: 64.59.144.19

(Either set of DNS servers will work for any Vancouver customers.)

Okanagan

Primary Server Name: nsc1.ht.ok.shawcable.net
Primary Server IP: 64.59.168.13
Secondary Server Name: nsc2.ht.ok.shawcable.net
Secondary Server IP: 64.59.168.15

Calgary

Primary Server Name: nsc1.so.cg.shawcable.net
Primary Server IP: 64.59.135.133
Secondary Server Name: nsc2.so.cg.shawcable.net
Secondary Server IP: 64.59.135.135

Edmonton

Primary Server Name: nsc1.ar.ed.shawcable.net
Primary Server IP: 64.59.184.13
Secondary Server Name: nsc2.we.ed.shawcable.net
Secondary Server IP: 64.59.190.245

Saskatoon/Winnipeg/Ontario

Primary Server Name: nsc1.nr.wp.shawcable.net
Primary Server IP: 64.59.176.13
Secondary Server Name: nsc2.nr.wp.shawcable.net
Secondary Server IP: 64.59.176.15

Have you involved your isp?
kieferschild 2388 Posts Sunday October 5, 2008Registration dateModeratorStatus April 27, 2018 Last seen - Feb 14, 2014 at 11:35 AM
+1
Helpful
can you go to the following directory:

C:\Windows\System32\drivers\etc

there is a file called hosts

open it with notepad

it should look like this:



make sure there are no more entries with random numbers and websites.

Can you do another ping to google and when you get the reply IP Address so for example in your last reply (173.194.33.113) - copy this IP and go to internet explorer and go to http://173.194.33.113

see if the webpage is resolved when you go to its IP address.
xpcman 18945 Posts Wednesday October 8, 2008Registration dateModeratorStatus May 23, 2018 Last seen - Mar 2, 2014 at 03:33 PM
+1
Helpful
I would suggest you to follow the steps mentioned below.



Step 1: Disable the IP Helper service
a. Hold the Windows key and type R, enter "services.msc" (without the quotes) and press Enter
b. Scroll down to the IP Helper service, right click on it and select Properties
c. In the dropdown box that says "Automatic" or "Manual", set it to Disabled and then click on "Apply"
d. Then click on "Stop" to stop the service from running in the current session
e. Click OK to exit the dialog

Step 2: Disable IPv6
Try uninstalling IPv6 on all interfaces, removing any IPv6 virtual adapters, and resetting the TCP/IP stack. To remove IPv6, go into the properties for each network adapter and either uncheck the box next to the protocol "Internet Protocol version 6 (TCP/IPv6), that will disable it, or select it and click uninstall, which will remove it off the computer. Then go into device manager and remove any 4to6 adapters, WUN miniport adapters, or tunnel adapters.
NOTE: You should do this for each network connection.

Step 3: Disable the DHCP Broadcast Flag
Important: This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

Back up the registry
http://windows.microsoft.com/en-US/windows7/Back-up-the-registry


Windows 7 cannot obtain an IP address from certain routers or from certain non-Microsoft DHCP servers
To resolve this issue, disable the DHCP BROADCAST flag. To do this, follow these steps:
a. Click Start, type "regedit" in the Start Search box and then click "regedit" in the Programs list.
If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
b. Locate and then click the following registry subkey:
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}"
c. In this registry path, click the (GUID) subkey that corresponds to the network adapter that is connected to the network.
d. On the Edit menu, point to New, and then click DWORD (32-bit) Value.
e In the New Value #1 box, type "DhcpConnEnableBcastFlagToggle" and then press ENTER.
f. Right-click "DhcpConnEnableBcastFlagToggle" and then click Modify.
g. In the Value data box, type 1 and then click OK.
h. Close Registry Editor.
By setting this registry key to 1, Windows 7 will first try to obtain an IP address by using the BROADCAST flag in DHCP Discover packets. If that fails, it will try to obtain an IP address without using the BROADCAST flag in DHCP Discover packets.
notit novice - Mar 7, 2014 at 10:59 AM
+1
Helpful
Finally after the factory reset got the internet back. Thanks all of you guys to put your minds to resolve this.

I still have no clue about what the problem was.

thanks again
kieferschild 2388 Posts Sunday October 5, 2008Registration dateModeratorStatus April 27, 2018 Last seen - Mar 7, 2014 at 09:47 PM
Hurray!

A resolution, thats what we like to see. Glad you got it sorted :)
me too. Thanks again all of you
xpcman 18945 Posts Wednesday October 8, 2008Registration dateModeratorStatus May 23, 2018 Last seen - Feb 10, 2014 at 09:46 PM
0
Helpful
I suggest you contact you ISP. They should be able to run a diagnostic check on the modem.

Good Luck
notit novice - Feb 11, 2014 at 08:23 PM
0
Helpful
kieferschild,

the sfc /scannow gives this message "Windows resource protection did not find any integrity violations."

CCX Diagnostic utility in windows 7 that runs the network diagnostic tests ran following tests and all were passed
1. Driver installation test
2. Card insertion test
3. Card enable test
4. Association test
5. Authentication test
6. network test

Adapter is Atheros AR9285 802.11b/g/n wifi adapter

laptop is windows 7 HP G62 notebook pc AMD Phenom (tm) II N850 Triple core processor 2.20 GHz 4 GB 64 bit operating system.

I also ran cmd (admin) Netsh int ip reset resetlog.txt and reboot to no effect
Thanks you a lot god bless you
kieferschild 2388 Posts Sunday October 5, 2008Registration dateModeratorStatus April 27, 2018 Last seen - Feb 12, 2014 at 07:44 AM
0
Helpful
Can you go to start > type "services" and open that up.

locate Windows Firewall and ensure that its startup is set to automatic and that it is started then try using recommended settings.

what antivirus software do you use?
notit novice - Feb 13, 2014 at 01:43 AM
0
Helpful
Kieferschild,

I am using McAfee internet security and after full file scan it did not show any virus. I switched its firewall off. Also I fixed the windows firewall problem but still no internet.

I am running out of ideas, pl. help.
kieferschild 2388 Posts Sunday October 5, 2008Registration dateModeratorStatus April 27, 2018 Last seen - Feb 13, 2014 at 09:54 AM
ac3mark 9319 Posts Monday June 3, 2013Registration dateModeratorStatus May 22, 2018 Last seen - Feb 13, 2014 at 10:46 AM
0
Helpful
If I may, Windows 7 needs to have a network location. It doesn't always prompt that. Set it to home, work or public.

Try that. Sorry it is too simple to not check!
notit novice - Feb 13, 2014 at 11:00 AM
0
Helpful
ac3mark,

thanks for the suggestion, but it is set to home always. You are right though, I feel it is possibly something simple.

kieferschild,

The windows firewall seems to be working fine now. It is not prohibiting any websites. I am away from my laptop currently but I will check the link later. thanks.
notit novice - Feb 14, 2014 at 06:07 PM
0
Helpful
Kieferschild,

appreciate your advice.

C:\Windows\System32\drivers\etc gives exactly the same results as you showed. google ping resulted in 173.194.33.115, I tried this but webpage is still not resolved.
kieferschild 2388 Posts Sunday October 5, 2008Registration dateModeratorStatus April 27, 2018 Last seen - Feb 16, 2014 at 09:21 AM
0
Helpful
So we can get to google using the IP address in firefox but not internet explorer?

can you get to google from firefox by using google.com?

can you (from another PC) go to http://malwarebytes.org and download the free version.

install it to your PC and run a quick scan. then a full scan.
notit novice 3 Posts Monday February 10, 2014Registration date February 16, 2014 Last seen - Feb 16, 2014 at 04:26 PM
0
Helpful
kieferschild,

the malwarebytes.org detected and removed a few items but website scenario is still same, I can go to google on its IP on firefox and see google search results but can't get any further to any links.

on the Ethernet after removal of mcafee and restarting it now identifies and shows internet access through Ethernet but still does not go to any website.

thanks for your help thus far.
kieferschild 2388 Posts Sunday October 5, 2008Registration dateModeratorStatus April 27, 2018 Last seen - Feb 17, 2014 at 08:24 AM
0
Helpful
Do you have another computer you can plug into your router?

It may be the router that is at fault here.
notit novice - Feb 25, 2014 at 10:18 PM
0
Helpful
I am running out of things to try, pl. suggest something.
ac3mark 9319 Posts Monday June 3, 2013Registration dateModeratorStatus May 22, 2018 Last seen - Feb 27, 2014 at 07:04 PM
0
Helpful
OK, slow down, and try to:
DESTROY ALL OF YOUR NETWORK CONNECTIONS FIRST. REBUILD THEM.

When I say destroy them , I mean , delete allof your network connections.

Then, reboot. Then use the OS to set up a new network. If you do not set a location, make certain.

Get rid of your transport before your get rid of your tracks..........

1 2 Next
Wifi connected but can't open any websites - page 2