Report

VLC video player suddenly has no sound [Solved/Closed]

Ask a question Connirae - Last answered on Apr 14, 2017 at 02:02 PM by April SOUL
Hello,

I have been using my VLC media player to play video recordings for a project I am working on. Everything has worked great, but suddenly, while listening and watching a video file, the sound stopped playing. I thought it was a problem with the recording at first, but I went back to the part i'd just been listening to and now it has no sound either.
So it seems to be a problem with the media player.
I did already check audio preferences and my S/PDIF box is already unchecked.
My sound on my keyboard is turned all the way up, and the audio isn't muted (at least no check by the "muted" on the audio menu.
I hope someone knows what to do. I'm bewildered!!! Hope someone can help. Thanks in advance!
The files are MTS files but I doubt that that matters. I've always been able to hear the sound on these files before.

See more 
Helpful
+242
plus moins
just go into settings and click on 'reset preferences' down the bottom, that should work
Was this answer helpful?  
Veer- Oct 24, 2014 at 02:17 AM
Reseting worked!! Thanks!!
akisha- Nov 21, 2014 at 08:44 AM
thanks :))
blue- Nov 23, 2014 at 07:48 PM
How do I open vlc media player after downloading?
Avetisiants- Nov 25, 2014 at 03:09 PM
Worked for me too! Thank you so much!!!
April SOUL- Apr 14, 2017 at 02:02 PM
Amazing, dude!!! It started working better than before!!!
Reply
Helpful
+139
plus moins
I tried all the suggestions in here, other than the Intel, which doesn't apply, and it seems my solution was just as simple.

I opened the control panel, clicked on the Sound option, and Windows said "Enhancements for this audio device are causing problems - Disable" - clicked yes for both devices and everything now works fine.
Geo V- Nov 7, 2014 at 05:42 PM
Thank you! Worked on Windows 8
vegn- Nov 13, 2014 at 09:07 PM
Great - it worked! :)
Danimal- Nov 15, 2014 at 01:48 AM
Thanks Batman!
Judy- Nov 24, 2014 at 09:24 PM
Thank you... It finally worked...
Helpful
+70
plus moins
open VLC > tools> preferences>audio > output module select waveout audio output> select speakers. save.
Alok- Oct 1, 2014 at 04:55 PM
Thanks.....It worked for me.
sri- Oct 4, 2014 at 09:25 AM
Thanks, my problem has been solved
NN- Oct 24, 2014 at 12:39 AM
Works for me! THANKS
ND- Nov 7, 2014 at 02:07 AM
Awesome!! workes fine
RXPG- Nov 16, 2014 at 03:45 AM
thanx its working
Helpful
+32
plus moins
Start playing a file on VLC.
Open Windows Mixer.
Scroll 'til you see the VLC icon.
Turn the volume up.
It's what I just did and it worked for me.
Kingsuk- May 25, 2014 at 10:05 AM
Thank you. You r a gem..... My prob solved.
Xross- Jun 6, 2014 at 03:39 AM
Play a file in VLC.. no VLC in the mixers..
Henz00- Jun 22, 2014 at 09:57 AM
I have the same problem as Xross. VLC is not in the mixers
freednc- Sep 17, 2014 at 08:02 PM
tried EVERYTHING else here and this worked....THANK YOUUUUU I feel so dumb...
Matt- Oct 19, 2014 at 11:48 AM
thanks a Lot
Helpful
+30
plus moins
Uggh! Now I have the same problem again.
Really puzzling! The sound came back on when I checked the box in VLC preferences --> audio, for "use S/PDIF"
After listening for about half an hour, with everything working fine, suddenly now the audio is gone again. The picture plays fine but no sound.
Paulger, I did check if my version is up-to-date. I'm on a mac, and have version 2.0.5 which my computer's "check for updates" program says is the most recent one.
If anyone has any more ideas to try, I'd appreciate it greatly!!!
Thanks,
BBBBBEEEE- Dec 26, 2013 at 08:20 PM
I was able to ^A to scroll through audio options until I hit on the right option. Never had to deal with that one before.
c- Jun 26, 2014 at 01:40 PM
That worked for me too Joe! thanks! saved me a call to HP:)
xuni- Oct 5, 2014 at 02:28 PM
O it worked !
yash- Nov 13, 2014 at 10:59 AM
thanx buddy I love you...u r like god to me
Kati- Nov 20, 2014 at 10:48 AM
@BBBBBEEEE..Thank you, you fixed my problem!!!!
Helpful
+14
plus moins
I had the same problem. I tried everything, changing audio-codecs, reinstalling drivers, reinstalling VLC player, rebooting system to earlier specs. NOTHING worked... then I tried simply deaktivating the soundtrack inside vlc player and then activating it again, and boom, problem solved... just wish I have'nt used 2 hours when the solution was so simple.

I hope this helps some of you.
willie- Dec 7, 2013 at 10:06 AM
worked great
JesseG- Mar 25, 2014 at 02:59 AM
Where's the soundtrack inside VLC??
Waqas- May 31, 2014 at 11:32 PM
goto audio => audio device and check the active device in the list.
solved my problem though.
Hotohori- Aug 5, 2014 at 04:58 PM
Audio > Audio Track > Disable: Then reanable.
worked for me as well thanks
mika- Sep 7, 2014 at 12:04 PM
Worked for exactly 5 seconds. Still have the problem. Tried everyhing above too.
Helpful
+8
plus moins
click on Speaker icon, then click on Mixer, you will see volume mixer options, that is where you can check if the sound is muted.
Helpful
+3
plus moins
hi, try try to restart your pc/computer.... and after restarting your pc/computer
it may have sound :) enjoy your movie :)
Helpful
+2
plus moins
Thank Paulger, for your suggestion. I'll do that!
I also just found that doing the opposite of what was recommended on another site actually fixed the problem for me. I CHECKED the box (in VLC Preferences . Audio) that says "Use S/PDIF when available"
Several people advised to UNCHECK that box. But mine was already unchecked so I just experimented to see if checking it would help and it did. That turned the sound back on for me.
Thanks again!
rfiscoechon 1Posts Tuesday September 17, 2013Registration date September 17, 2013 Last seen - Sep 17, 2013 at 04:31 AM
@bewildered , to see that "use S/PDIF when available", go to Preferences, Audio, Output(click on the dropdown menu/tab and choose "Win32 waveOut extension output"


In my case it didnt solve the problem. :(
Jaimz- Nov 12, 2013 at 12:17 AM
Thank you!! I just installed the Windows 8.1 update and this happened to me too. It worked for me so thanks :)
jhgghjjhggh- Feb 10, 2014 at 03:18 AM
thank you soooooo much.
chubbyraven- May 22, 2014 at 03:23 PM
Thank you so much :)
SiD- Aug 1, 2014 at 03:46 PM
@refisoecheon It worked... Thanks a ton
Helpful
+2
plus moins
Go to sound settings -> and select applications tab
Here they will show the current status of applications running
Simply enable the vlc player frm list. This worked fr me
Helpful
+2
plus moins
VLC Player No Sound Solution:

Solution 1, Unmute your VLC Player;

Solution 2, select Tools > Preferences menu to open Preferences dialog, select Audio on the left, and confirm Enable audio is checked. Then Click Output module drop-down button and try a different default.

If the above solution is not fit you or can't solve your issue, in this case, we highly recommend an ultimate and commonly used method to solve "VLC not playing MKV files" - convert MKV to VLC Player more compatible formats.

Here is a step by step guide on how to convert MKV to VLC supported formats at: http://www.faasoft.com/articles/vlc-mkv-solution.html
Helpful
+1
plus moins
experienced this as well and spent around two hours tinkering with all the options, it was finally solved after I muted then un-muted the audio. What a waste of two hours that was =))
Helpful
+1
plus moins
I activated, deactivated and activated the S/PDIF box and still can't get any sound. The mixer is fine. Files work with divx, but divx is crap since it doesn't launch movies by dbl clicking movie icons but instead opens up a divx browser from which you then need to find appropriate movie files. Vlc sound stopped woyking when some windows updates automatically uploaded. Worse than a virus!
Helpful
+1
plus moins
Try this:

https://wiki.videolan.org/VSG:Audio:Output/
Helpful
+1
plus moins
I ran into this problem while teaching my students. In between classes I worked on editing a movie and plugged my headphones in. When class started back up, I unplugged the headphones and went back to my speakers. No sound. I tried all of these options above one at a time, painstakingly making sure I followed every step correctly. Nothing. I restarted the computer. No sound.

After much aggravation, I decided to open up the movie I created to watch it. I had sound again. I closed the movie down, opened up my music files, and resumed business as usual.
Helpful
+0
plus moins
Also, I did try closing the program and opening it again.
Helpful
+0
plus moins
hi,

do you have a proper version of the VLC?
I had similra problems and I was start searching newer version. I found it here: http://softfinder.com/vlc-media-player

website is new (I think) but app from there works and fixed my problem.
Helpful
+0
plus moins
See also the article : "Video Overlay settings at zero after changing scheme" from intel

This solved my problem. It was odd because I had audio but no video in ALL video players. It took me quite some time to figure mine out. And IT wasn't even a codec problem or anything wrong with the various players I tried to use.

Obviously my computer has a intel graphics driver, but you may have a similar problem. Worth a shot. I was switching schemes as I was using a HD TV as a second screen on extended settings and then switching back all the time of late.

http://www.intel.com/support/graphics/intel915gm/sb/CS-029329.htm

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!