Ask a question Report

Regedit is disabled by the administrator [Solved/Closed]

9845 6Posts Tuesday May 27, 2008Registration date February 2, 2009 Last seen - Latest answer on Nov 10, 2012 03:12PM
Hello,
When i run Regedit it displays " Regedit is disabled by the administrator" what to do
Read more 
Answer
+355
moins plus
You can do it the hard way or do this:

Start>>Run>>gpedit.msc>>System>>Prevent Access to Registry Editing Tools (set this to DISABLED)

Finished!

Ricky- Oct 29, 2012 06:35AM
brilliant!!! thanks
deeds- Nov 2, 2012 12:36AM
thanks it works
Ben- Nov 9, 2012 08:47PM
hi,my computer doesn't have Prevent Access to Registry Editing Tools,how?
Mr. Myat Kyaw- Nov 10, 2012 03:12PM
Thanks
Answer
+76
moins plus
First Method:
Click Start -> Run -> gpedit.msc -> User Configuration -> Administrative Templates -> System -> Prevent access to registry editing tools -> Right Click Properties -> Set it to Not Configured.


Second Method:
Click Start -> Run. Type this command in Run box and press Ok.

REG add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DisableRegistryTools /t REG_DWORD /d 0

Then a prompt will come up with this question: Value DisableRegistryTools exists, overwrite (Y/N)? Type yes and hit Enter.

After u did that also type this command in the run box and hit enter.

REG add HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DisableRegistryTools /t REG_DWORD /d 0

Then it will also come up with the question: Value DisableRegistryTools exists, overwrite (Y/N)? Type yes and hit Enter.


Third Method:
STEP1. Disable as much as you can from your startup. Remove programs from your startup folder and such, so as not to lag down the bootup process.

STEP2.Create a new shortcut on your desktop, point it to "C:\Windows\regedit.exe"

STEP3.Log off, then log back on.

STEP4.As soon as you see your desktop, double click on the shortcut. The system does not check for policies until a few seconds after it booted up. If you click on the icon fast enough, it should let you get in.

After you close it though, it will not open unless you redo step 3 and 4.


Fourth Method:
Getting into the registry editor by making a vbs script in notepad:

Open Notepad and copy this script into it. And save it as regtool.vbs on your desktop.

VBS SCRIPT(select everything and copy into notepad and save as regtool.vbs):

Option Explicit
'Declare variables
Dim WSHShell, rr, rr2, MyBox, val, val2, ttl, toggle
Dim jobfunc, itemtype
On Error Resume Next
Set WSHShell = WScript.CreateObject("WScript.Shell")
val = "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistryTools"
val2 = "HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistryTools"
itemtype = "REG_DWORD"
jobfunc = "Registry Editing Tools are now "
ttl = "Result"
'reads the registry key value.
rr = WSHShell.RegRead (val)
rr2 = WSHShell.RegRead (val2)
toggle=1
If (rr=1 or rr2=1) Then toggle=0
If toggle = 1 Then
WSHShell.RegWrite val, 1, itemtype
WSHShell.RegWrite val2, 1, itemtype
Mybox = MsgBox(jobfunc & "disabled.", 4096, ttl)
Else
WSHShell.RegDelete val
WSHShell.RegDelete val2
Mybox = MsgBox(jobfunc & "enabled.", 4096, ttl)
End If

Open regtool.vbs And there you go!

TIFFIE- Jun 26, 2010 03:11AM
YOU ARE THE BEST.WHEOW.
LuX- Jun 30, 2010 03:42PM
i dont have PREVENT ACCES to registry editing tools...what should i do?
Avinash- Jul 6, 2010 03:19AM
Thanks ND! second method worked for me :-)
raj- Jul 6, 2010 10:31AM
registry edit is disabled
dowalex- Jul 6, 2010 10:13PM
Amazing! 2nd one worked perfectly
Answer
+62
moins plus
This gives back access to REGEDIT :
http://www.dougknox.com/security/scripts_desc/regtools.htm
THANKS TO DOUG KNOX!!!!!!
regtools.vbs - Disable/Enable Registry Editing tools in Windows
© Doug Knox - rev 01/10/2000 This code may be freely distributed/modified.
Usage: Download regtools.vbs Save the file to the folder of your choice. Double click the VBS file. The VB Script file will check for the appropriate value and if not found will create it. If the value was found, it will be toggled to its opposite state and you will be informed that you need to log off/back on or restart your computer. One note. This change is made in HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System. Disabling the tools takes effect immediately. Enabling requires a restart. This script can be viewed in Notepad or any text editor, as to the specific Registry key and value that are updated. Your antivirus software may report this script as potentially malicious, or a possible virus. This is because the script writes to the System Registry.

Then go to regedit and edit the following
HKEY_CURRENT_USER
SOFTWARE
MICROSOFT
WINDOWS
CURRENT VERSION
POLICIES
EXPLORER

ONCE YOU GET HERE START AT THE BOTTOM OF THE LIST AND DELETE THE ENTRIES----YOU CAN DELETE THEM ALL BUT I LEFT THE TOP ONE WHICH IN MY CASE WAS â€oe AB DEFAULTâ€

Then, check the registry to see if "NoDispCpl" had been added.
"Deny Access to the Display Settings"
http://www.winguides.com/registry/display.php/167/

User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
\System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows
\CurrentVersion\Policies\System]
Value Name: NoDispCPL
Data Type: REG_DWORD (DWORD Value)
Value Data: (0 = disabled, 1 = enabled)
In regedit use the edit option to FIND any of the following entries in the registry
DisableRegistryTools delete any entries found
DisableTaskMgr delete any entries found
NoDispCpl delete any entries found
Virus Alert!
Also if the worm put VIRUS ALERT! By the time go control panel---regional and
Language----click customize---------and delete VIRUS ALERT!

rsrrohit sumoboy - Mar 16, 2010 01:22PM
Yea man your trick worked . None of the tricks before worked. But because of you I did it in 10 seconds flat!!
Deethrem- Oct 22, 2009 02:34AM
Thanx. Problem solved in less than 30sec.
Razi- Nov 14, 2009 04:19AM
Thanks brother
Spettro- Mar 9, 2010 12:23AM
Hi,

I tried out the solutions given below. But, as soon as I enable the registry, it gets disabled after about a couple of seconds. I figure this would be because of the virus that is still present. Should I first run any malware/spyware detection anti-virus program before applying any of the fixs suggested in this forum? If so, can you guys please suggest which is the best one?

Thanks in advance for your help!

-Spettro
Answer
+28
moins plus
regedit has been disable by admin

Answer
+24
moins plus
// 100% WORKING SOLUTION //



First, I click the START button, then click RUN, the I type CMD at the RUN Window. On Windows Vista I click the START button and type CMD at the search input field.

Then, at the CMD window, I type: "reg add HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DisableRegistryTools /t REG_DWORD /f"

Enable regedit

And that's it! Now I'm able to edit the system registry and remove any virus, adware or any badware from the computer.

Debarati- Jun 15, 2010 01:55AM
Sorry that did not work even after saying that the operation was completed. Do you have any other way?
Answer
+8
moins plus
Thanks sir

Answer
+8
moins plus
how can i enable regedit

Answer
+5
moins plus
my registry is disabled what to do

Answer
+4
moins plus
thanks for u r code

Answer
+4
moins plus
Very thanks

Answer
+4
moins plus
Thankyou very much It's working perfectly

Answer
+4
moins plus
thanks a lot .......u r my god........ i thought reinstalling the os was the only solution.......but thanks to u i learnt something very useful......now onwards i ill help all my friends who faces this problem......keep up the good work.......

Answer
+3
moins plus
You can use the Task Manager Fix tool to enable the disabled Task Manager.

Get the tool from http://www.taskmanagerfix.com

Answer
+2
moins plus
thank u my dear!!!It works very Good,Thanks for ur help

Answer
+2
moins plus
Thanks!!! I Really Appreciate It!!!!!

Answer
+2
moins plus
Thanks Lotz.....!!!!!!!!

Answer
+2
moins plus
Thanks for your support

Answer
+2
moins plus
It was very usefull for me. Both the problems got resolved. regedit disabled and taskmanager disabled.
I heartly appreciate this website owners. Keep up the same work going on.

Answer
+2
moins plus
thank you very very very much i though i will format my computer for 5th time in this weak lol
God Bless

santy hire from philippines

Answer
+2
moins plus
Use the Group policy editor
%windir%\system32\gpedit.msc
User Config\Admin Templates\System\Prevent Access To registry Editing Tools=
"Not Configured"

1 2 Next
This document entitled « regedit is disabled by the administrator » from CCM (ccm.net) is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly.

Not a member yet?

sign-up, it takes less than a minute and it's free!

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.