Ipod 5th Generation does not turn on and does not charge.

Michael - Jan 4, 2018 at 06:10 PM - Latest reply: kieferschild 2387 Posts Sunday October 5, 2008Registration dateModeratorStatus April 12, 2018 Last seen
- Jan 9, 2018 at 09:49 AM
Hello,

I have a Ipod 5th generation video 80gb and it will not turn on and will not charge with a good working cord. I have made sure that the hold is not on and that the ipod has had no other problems before this. Battery was work just fine and would charge before this problem. Now when I plug in the cord the ipod does not do anything, does not charge and does not turn on. I have tried the 'push down the menu and center button at the same time' but this has done nothing. Tried holding down the buttons for five minutes with the cord plugged in and without the cord plugged in. I was hoping that there might be a trick to make it turn on. I think that the logic board may have fried but I do not know how to know if that is the problem. This ipod does have the original memory card in it and I can not hear it turning inside, can not feel the vibration of it working as well. This is why I think the problem might be the logic board.

See more 

1 reply

Reply to this topic
kieferschild 2387 Posts Sunday October 5, 2008Registration dateModeratorStatus April 12, 2018 Last seen - Jan 9, 2018 at 09:49 AM
0
Helpful
Solution 2:-

Try to restore your iPod device with iTunes.

Connect your iPod to computer using USB cable and open iTunes app.

If your iPod device appears in iTunes, select and choose reStore option in the summary panel.

If your iPod does not appear in iTunes, try to force your device into recovery mode.

Note: Please do not restore your iPod until your have a backup of your iPod. Because this restore process will erase your iPod data.
Respond to kieferschild