Problems Vista Media Center after SP2 install

[Closed]
Report
-
 declension -
Hello,
I have Vista Premium 64 bit and after installing Vista SP2 Media Center doesn't play videos anymore. Both Windows Media Players (32&64 bit) work fine, just Media Center does not show the video while playing the file (avi & wmv) or exits without playing from video mode (mpg). In case of avi or wmv if I try to stop the player it almost always crash. I had Vista Codec Package installed before installing SP2 and it worked just fine. After installing SP2, which triggered the problems I tried with other codec packs too but no one solved them.

I hope anyone can help me with a solution.

Thank you.

6 replies

I have the same problem too. WMC will not properly end or stop my videos since SP2 was installed, and pausing the videos for a long time will make a video error. If anyone has a fix or solution, please e-mail me:

Email Id removed for security
3
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2821 users have said thank you to us this month

I watched my DVD Train Ride Through the Rockies at home, and went to my hotel with Hi Speed WiFi and Updated SP2/ on my Windows VISTA and the DVD Capability went away; "Unrecognised Disk in Drive E:".
I Reversed the Update (from the Windows Update Platform you can "uninstall" any Updates, and I found it on the list and removed it and all is well in DVD Playland now, except I cannot/willnot Update my VISTA to SP2 anymore - - -
I have the same problem.

I can play audio files using Windows Media Player. However for DVD's, i can see the video but there is no audio...
With thanks to CX23882-19 at http://thegreenbutton.com/forums

Here's a workaround to get AVI/MKV playback working on Windows Media Center, whilst keeping SP2. I've identified the buggy component to be ehplayer.dll.

Firstly, you need to take ownership of ehplayer.dll in C:\Windows\ehome:
1) Open an elevated command prompt (i.e. right-click on Command Prompt and choose Run As Administrator
2) Go to C:\Windows\ehome
3) Type:
takeown /f ehplayer.dll
cacls ehplayer.dll /G <username>:F
(so on my system it is cacls ehplayer.dll /G HTPC\cdldt:F)

Now you have access to ehplayer you can replace it. The version you need (18000) can be downloaded from here:
http://www.quantexzone.com/files/ehplayer_18000.zip
I have no intention of infecting anyone's PC with malicious software, but if you don't trust me you can get this from your side-by-side directory. Go into C:\Windows\winsxs and search for ehplayer. You should see several versions of ehplayer.dll listed. One of them should be build 18000 (you can tell from the directory name).


Back in C:\Windows\ehome, rename ehplayer.dll to ehplayer.old and then copy the 'new' version (i.e. build 18000) into C:\Windows\ehome.


That should be all you need to do. Of course, you've now got mismatched versions of Media Center components, so it's possible that there could be stability issues with this, but so far it's been fine for me. Good luck!

It appears that ehplayer.dll has been broken since build 6.0.6002.18005. The latest build I've identified as working is 6.0.6001.18000, but it would be interesting to hear if anybody has a newer build than that which is working.
> tgab
does this work for the TV channels freezing? [such as national geographic, etc] like every time i go to internet TV and click on a channel it freezes and the screen just goes black and the video doesnt load :[ I'd like to be able to fix this. plz help >.<
> tgab
I can not get by the UAC to let me rename the file. I disabled UAC and tried using the command prompt with admin privs, but it still would not let me. Ideas???
> one800dave
Never mind... I forgot to run CACLS... :)
I did as guided but it crashed even worse this time, then i found the winsxs\ehplayer.dll and tried with that and now it works perfect, i think the file linked is for 32bit systems.
Posts
2
Registration date
Wednesday April 22, 2009
Status
Member
Last seen
June 9, 2009

hi,

try to do a system restore to restore your computer to a earlier time when you did not yet install the SP2.

>start
>accessories
>system tools
>systemm restore
Oh... sorry for the double post. Uninstalling / Reinstalling did not help... even using the newest version did not solve anything.
worked for me. +1 =)

hope this works for others.