Seagate internal hard-drive not detected

Closed
arsalan159 - Updated on Jan 2, 2019 at 02:06 PM
 Blocked Profile - Jan 7, 2019 at 01:46 PM
Hello,

I have a Seagate HDD model ST200DL003
2Tb. I turned my PC off, and the next time i turn on my PC the HD is not recognised. Hard power is working good and disc's are turning around, but when I go in bios it does now not show up. I checked the device management and found the same. What's the problem?


System Configuration: Android / Chrome 71.0.3578.99

2 replies

xpcman
Posts
19532
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
1,969
Jan 2, 2019 at 02:19 PM
I suggest you check the cable at both ends. If it's connected then you probably have a dead drive and nothing will fix it.

Good Luck
0
tnx for your respond but i allrady check that...with another cable...and another PC
0
Blocked Profile
Jan 2, 2019 at 03:23 PM
If you move the part to a another rig, and it does the SAME thing, it is bad! Does the drive meet the PC specifications.
0
arsalan159 > Blocked Profile
Jan 2, 2019 at 03:39 PM
yes the drive meet the PC specifications i was use hard in my pc untill 2 day's ago...idk..are you mean the drive is dead?
0
Blocked Profile
Jan 2, 2019 at 03:50 PM
If its does the same thing in both rigs, then yes. Especially if you say you used it until two days ago! If it doesn't show in BIOS, and you double checked connections as XPCMAN suggested, then yes, it might be "FRIED"!
0
thank for your respond but could you explain me what is connections as XPCMAN please?
0
Blocked Profile
Jan 7, 2019 at 01:46 PM
the connections look like this:


I thought you tried it already!

0