Seagate internal hard-drive not detected [Closed]

Report
-
 Blocked Profile -
Hello,

I have a Seagate HDD model ST200DL003
2Tb. I turned my PC off, and the next time i turn on my PC the HD is not recognised. Hard power is working good and disc's are turning around, but when I go in bios it does now not show up. I checked the device management and found the same. What's the problem?


System Configuration: Android / Chrome 71.0.3578.99

2 replies

Posts
19542
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
1,666
I suggest you check the cable at both ends. If it's connected then you probably have a dead drive and nothing will fix it.

Good Luck
tnx for your respond but i allrady check that...with another cable...and another PC
Blocked Profile
If you move the part to a another rig, and it does the SAME thing, it is bad! Does the drive meet the PC specifications.
> Blocked Profile
yes the drive meet the PC specifications i was use hard in my pc untill 2 day's ago...idk..are you mean the drive is dead?
Blocked Profile
If its does the same thing in both rigs, then yes. Especially if you say you used it until two days ago! If it doesn't show in BIOS, and you double checked connections as XPCMAN suggested, then yes, it might be "FRIED"!
thank for your respond but could you explain me what is connections as XPCMAN please?

the connections look like this:


I thought you tried it already!

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!