Trouble with Linksys router WRT54GS

johnkwit Posts 4 Registration date Monday June 16, 2008 Status Member Last seen June 17, 2008 - Jun 17, 2008 at 06:17 PM
 fatawu - Jan 8, 2014 at 11:44 AM
I have a new Linksys router WRT54gs and a new Dell laptop.
The router works well with the cable attached but when I go to wireless
I get a strong signal but unable to get on the internet with WEP security.
With security disabled the wireless works fine. But will not connect to the
internet with WEP security on. I tried to use the CD install disk that comes
with the router but ir does not help.
Any help would be apreciated

49 responses

so you have a lenovo laptop, linksys wrt54g wireless router and a lexmark wireless printer. And you wants to secure your wireless network. Just follow the instructions ---

1> connect your lenovo with the WRT54G at port no. 1 it is very imp. to hardwire your computer, also check for the light status of the router to ensure that it is connected.
2> access the router setup from a web browser (may be using, the default address of your router, and admin as the password.). You can also go to if you need more help to access your router setup.
3> at the top click on wireless on the BLACK bar at the top.
4> under wireless click on wireless security on the blue bar.
5> select the security mode as WPA-PERSONAL (best encryption and supported by all devices).
7> in WPA Shared Key type: "superman" or any thing else but it should be at least 8 characters long. and you should remember it as this will be your wireless password.
8> the Group Renewal key should be 3600.
9> Click on save settings at the bottom.

1> Under Wireless, click on Basic wireless settings.
2> MODE: mixed
4> Channel: 11


Now u jest need to connect your laptop and printer to this new secured wireless network using the security key and I am damn sure it will work.

enjoy !!!!!!!!!!!!!!!!!

thanks a lot, it worked!

Thanks for your contribution. My old Linksys router WRT54GS works fine with my Dell laptop before . I bought a new hp lap top with Vista a month ago. The HP laptop with its customized wireless connection system automatically connect the computer to the exsiting home wireless net work. But since then, my dell laptop can connect via hard wire through the router, but no wireless net work anymore. You can see the home wireless network profile is avaiable to choose from the screen. My computer indicates that I have an excellent signal from the router, but when I try to open a browser the screen says it cannot be connected to the internet. I was wondering there is an issue with IP address , but not expert to tell. Can you help?Thanks in advance
Pillai81 > Amido
Feb 11, 2009 at 07:00 PM
HI Shashank,

i tried the exact same thing as per your instructions by pressing the reset button for 30 seconds and then changing to port 1 but my browser shows me a page as mentioned below.

Management Mode
Firmware Upgrade

File Name:

Apply Reset

this is what I get. please help I am pretty lost here

best regards
Shashank Singh > Pillai81
Feb 14, 2009 at 02:52 AM

I don't know the model and version of your router, you can find them at the back of it.

1.Go to
2.type the model no. on get downloads the version and then below, you will found firmware, under that click on download and save the bin file to the desktop. connect this computer directly to the port no.1 of the linksys router.(Very important, donot try this wirelessly )
7.Give the path of the downloaded file from the desktop and click on apply.
8.Now you can follow my previous steps.

Good Luck.
i have a problem and the router has the installing cd in the box but when I get to the last step when it says its wiating for the router and the it is an error that says that I need to diconnect the old router but I dont have one and it also says that I need to check the wires but they are fine I dont know what the problom is but can you tell me?
i am a LINKSYS TECH. SUPPORT ENGG. from India so you are sooooooo close to the solution of your problem.
Just go to select the model no.of your router and you will get step by step help to setup your router. you can also call linksys tech. support and I am here to solve your problem.
if this is a new router then connect it to your system through ethernet cable and go to internet explorer and type at the add. bar it will prompt for the password. leave the user blank and type admin in the password linksys setup page should open. now click on the WIRELESS TAB and on the basic wireless settings change the defale SSID NAME to your girlfriend's name and also click on reset security and click on save settings. reload the page and now go to wireless security tab and select WEP in the security tab. now type 10character password in the KEY 1 field directly and click on SAVE SETTINGS and that's it. Now when you connect to your network you will have to enter your 10 char password in your DELL LAPTOP and it should work fine now. call tech support or go to the above link for further assistance
Shashank singh
I have a question, Umm, my modem doesnt have an extra ethernet cord hole, how else can I hook it up? My modem is comcast model number TM502G.
Hi there !
I cannot enter my linksys wrt54g. Do you have a solution to this problem.
Futher more I am trying to connect my router to a wireless printer that I have got lexmark 4350. The printer asks for a key, nyt I have 4 keys ?
Shashank ... I have a little different problem than was posed before. I have a Y510 Lenovo laptop and a Lexmark Z1420 wireless printer. Both were talking to my WRT54G Linksys router perfectly until I tried to turn on the security. When I was done, the laptop could no longer talk to the router wirelessly (so no internet connection) and it couldn't communicate with the printer. I have tried to undo everything but have not been successful. Is there any way that I can reset everything so I can get back to square one and start all over again?
hello I have some trouble with my linksys WRT54GS router with speedbooster I want to install my adaptor on to my zoomstorm desktop pc but it is saying to us a disk I tried the router disk but it doesnt work im sure I had another disk for the adaptor but my friend says there isnt so could you help

I USE Linksys, MY HP with XP is in one room with the modem and router, my new dell vista is in next room.

The main xp "flies", my dell laptop vista flies, my dell Vista desktop, lags

Any basic suggestions


If you have WRT54G:
1) simply push reset for 10secs, or until the orange light goes off. Continue to hold the reset button until the green light turns off. (this should return the router to factory settings)
2) go to the the computer with wireless capabilities.
3) Open internet explorer
4) type in the address line
5) when it asks for user/pass only put 'admin' in the password line. Some newer models require both. Then press enter
6) You will also want to upgrade the firmware on the router if it doesn't have the most up to date version, this will be an admin option. Check the version number on the linksys web-site
7) Configure the router, I recommend WPA2 for security and of course change the login password for your router config to keep people out

Keep in mind that every time you save a setting you will have to re-connect to the internet

Resetting WRT5AG should fix the problem. But in random period of times, it will come back again. The permanent solution was to apply the latest official firmware - PLUS- applying with the final firmware called DD-WRT (open source replacement).

This should fix the problem permanently, at least for him
"If you have WRT54G:
1) simply push reset for 10secs, or until the orange light goes off. Continue to hold the reset button until the green light turns off. (this should return the router to factory settings)
2) go to the the computer with wireless capabilities.
3) Open internet explorer
4) type in the address line "
OK but I should connect by ethernet cable and I cannot doi it , doesnt work. :(
Hello, Shashank...

I have just gotten a linksys wrt54g broadband router, and went through the installation process, both on the web-based utility, and from the cd it came with. I can't bring up any webpages, as it tells me, after setting my password:

"The Router is not able to connect to the Internet. Try turning the Cable/DSL Modem OFF and back ON again. Do you want to try again?"

I do as it says, and click YES, and it just keeps telling me to try again.

Also, I bring up the View Network Connections window on the computer, and it tells me that it's connected, and everything is working. I just can't bring up webpages.

I unhooked the router, and hooked the modem back up directly to my computer, and it worked that way. I was able to bring up webpages, and stream videos. I know it has something to do with the router, and I wish I could figure it out.

Can you PLEASE help me!? :(

Didn't find the answer you are looking for?

Ask a question
Shashank Singh
Oct 10, 2008 at 04:22 PM
at the back of the Linksys Router you will find a reset button press and hold it for about 30 sec. (Make sure you are holding the button properly.),
it will reset all the settings of the router.
after that reboot the router, connect your computer with port no. 1 , and then try to open from the Internet explorer of your computer.
it will give you a message "The server at, WRT54GS require a USER NAME and Password. "
Now type "admin" in the password and it will take you to the LINKSYS ROUTER SETUP.
shelliecc04 Posts 3 Registration date Saturday January 30, 2010 Status Member Last seen January 30, 2010
Jan 30, 2010 at 06:37 PM
I have a WRT54G router and cannot get it to work again. We were able to get the wireless router working earlier, but when we tried to secure the network we lost connection and have not been able to set it up again. I could use all the help possible I am not very good with technology. How can I install or get it to work again?
I'm going nuts now. This page doesn't open. I have changed it into bridge, now I wanna put it back...
Try and follow this step by step router installation guide

hope it helps
Mar 20, 2010 at 10:23 AM
Mine does the same thing
voyer501 Posts 2 Registration date Saturday December 6, 2008 Status Member Last seen December 7, 2008
Dec 7, 2008 at 04:32 PM
ok just recently I had brought a new computer desk and I had plugged out my router after re assembling my computer I plugged the router back in but for some reason it did not turn on or anything I tried it in every outlet in my home but to no avail I would like to no if the router is no longer good to see if I have to buy anotherone
everytime I type in admin under the password it just keeps giving me the same tab
are you sure that has'nt been changed to something else
are you leaving the username blank

and then using admin
for only the password
I am having a problem with my router. I keep getting the "limited or no connection" error. I have tried installing new firmware, disabling firewall, reseting the router. It won't connect on that one computer, but it connects to my iPod and other computers in the house. I'm not really sure what to do...I'm stumped. Any help would be grateful!

We fixed the connection limited or no connection. Plug both the dsl ethernet line from the dsl modem to the four ports grouped togther this goes for the ethernet cable to pc also. But be sure to configure your routers security settings first. Then unplug it all then plug back in, it should work then.
Is their any other way to reset my LINKSYS ROUTER WRT54GS
64 bit and wrt52g2 are like oil and water.

And screw India support.
forgot my password
i net cafe with 35 computer whice router is good forme
Aug 16, 2008 at 10:55 PM
The last router I set up was You can reset the routers IP address By holding in the reset button on the back of the router for up to 45 seconds, but this will only reset it to default, which will be something like or, or, you really need the manual that come with the router beacause not all of them set up the same, similar but not the same, It will ask for a login name "admin" and password which is blank. Just hit enter, but I have set up a router where this was backwards. The login name was blank and the password was "admin" . Good luck
The Linksys WRT54GS address is and the problem may be that you are using a pass phrase to set up the WEP. As far as I know, Dell doesn't support the use of pass phrases. Try making up your own key using 26 charecters. Use any number and the letters a,b,c,d,e,and f.

I'm trying to set up my wireless network with a Lynksis WRT54G. Everything works fine except when I try to change the security mode. It's setup on disable and when I try to change it to anything else it refreshes the box back to disabled before I can hit save changes. I'm just wondering how I can get around this and change my security mode. Thank you.
Try to upgrade the firmware of your WRT54G, you will find the step by step instructions on
Also please hardwire your computer to the router before trying to do this.
kishore > Shashank
Feb 7, 2009 at 03:07 AM
Hello Dear Shashank,

I am facing the problem that, when I connect the linksys directly to my switch the internet not coming but when I connect to a single computer then the internet coming. why its like that. can you help me please.

TMC > Shashank
Feb 19, 2009 at 11:24 PM
Hi Shashank,
Grateful for any insights. I'm having similar troubles connecting a WRT54G to a Dell Vista PC. The wired connections work but the wireless link does not show up on my T43 XP laptop. The Vista PC has been updated with Microsoft Update, the Wrt54g is V8 and I updated its firmware to 8.00.5. I tried setting WEP security. Very curious!
I too had the same problem, wireless connectivity was great but no internet connection via wireless, and I solved it. I had to turn off the Cable Modem for 30 seconds. I then unplugged and plugged the Linksys back in (may or may not be necessary) and then plugged the cable modem in. I turned on my laptop and I was able to connect to the internet via the wireless.

This solution assumes everything else in your configuration is correct such as security et al. Despite all of the other suggestions out there, which I had tried, this is what worked for me.
Hello all. Kind of having the same problems. I have a WRT54G. I'm trying to set up my Tivo wireless and use my laptop. Tivo has to be WEP encryption to work. When I set up WEP in suddenly I cannot connect the laptop. It finds the SSID but it says limited to no connectivity and I have no internet. I read on here that DELL does not accept pass phrases. Could this be part of my issue? Also when I try to access if my firewall is active it won't load right. If I shut it down it loads fine. I'm using Zonealarm. Can anyone tell me how to change settings in Zonealarm so I can keep it up when I'm using the web based interface? Thanks
hey man I had the same problem. What you jhave to try is leaving the router off for about 15 minutes then try again. If not try by changing the pSSWORD TO ANOTHER THING. rHAT ALSO WORKS.
I never did get the laptop to work on WEP encrytion. Had to go to a different network adapter for the Tivo that excepts different encrytion. As for typing in Admin I was having a problem with this too. I shut down my virus protection and then it worked fine. Anyone have Zone alarm that knows how to set it up so you can go into the router without shutting down Zone Alarm?
Just some experience I had with this router that might help someone else -

My first wired connection set up worked great and all the wireless devices in the house connected fast. Problems started wireless or wired Vista 64 bit computer connection became flaky. Most of the times it would just not work or not get an IP address from the router. Very frustrating. I spent time with Linksys support staff and nothing worked. What this did help with was understanding my new Linksys router a little better. Initially I also thought the problem might be with Comcast. There were a lot of postings talking about them registering MACs and not letting more than one MAC register to. Finally I concluded that this was not the case.

I think there may be specific issues with Vista 64 bit (mabye 32 also??) OR something that may have been causing this problem. Finally, I assigned a static IP address (a few numbers offset from where the router starts assigning IPs which is to my Vista wireless card and this helped fix the problem. But it took me a whole day to get this working. My XP computers worked just fine and I didn't have to assign static IPs for them.
Yes, for me it definitely was a Vista problem. My wireless was dropping constantly and although I could see the network and the signal was good, it had trouble connecting. I found the solution here:
It works perfectly now!
my linksy router not enough signal does anyone know what wrong ?
You mentioned that the laptop is new. Don't use WEP. Use either WPA or WPA2. It's stronger and works where WEP doesn't.

Problem connecting to a wireless network using WEP? Try using wpa personal as your security mode because vista has a dificulty connecting to a wireless network using wep. I tried it and it works.