Trouble with Linksys WRT54G router [Solved/Closed]

Lucas - Jun 14, 2008 at 07:55 PM - Latest reply:  robort1961
- May 26, 2016 at 04:12 PM
The only computer I have is a Dell Insprion E1505 laptop and it is connected to a "COMCAST" cable modem. Windows XP, not Vista is installed. I purchased a LINKSYS WRT54G wireless router. I installed the setup disk and connected the modem to the router, and the router to the computer as step one, but when step two had me disconnect the router from the laptop so it could connect via wireless network, it just says "easylink advisor could not establish a wireless connection with the router." Again, I AM able to search the web if the router is hard lined into the laptop, but that defeats the purpose of the router. This very well could be a network configuration issue, but i'm not sure. Any help would be appreciated!
"wireless network connection" shows my laptop has a 1390 wlan mini card.
thanks
Lucas, USA, Michigan
See more 

81 replies

Best answer
189
Thank you
On the main setup page the ""Internet Connection Type"" should be
on ""Obtain IP Automatically - DHCP . Click on the Save Settings
button.
Now click on the sub tab ""MAC address clone"".
- Click on enable
Click Clone & click save settings
Check WAN Ip on Status page of router ....
If getting Valid Ip .... try going online
If not ... power cycle for 4-5 minutes & then agian check the WAN Ip address .....

http://forums.linksys.com/...

Thank you, Mark 189

Something to say? Add comment

CCM has helped 1771 users this month

These instructions and the "flushdns" command work with Charter cable modems and the WRT54G also. I am grateful to you for posting them. The router was connecting wirelessly but I could not connect to URLS, only IPs in the browser. The flushDNS worked for that. Also, I am using openDNS with this router since Charter reroutes Google searches and using openDNS solves that problem. I do wonder if that's what caused the hangup on the router connecting properly and if that's why the flushDNS command worked....
I am not one to usually comment on the helpful hints I get online, but in this case, I need to applaud Mark and the great instructions for getting this WRT54G working correctly. Thank you for taking your time to post these simple instructions here.
Thank you, thank you, thank you. So many confusing (but I'm sure brilliant) suggestions; this one was simple and worked like a charm. Thank you, Mark.
I am so happy I found this! Yeah look it me, I'm finally connected to the internet through my router! :)
Please try to reset your router and configure it once again and then is it working or not for more information you can visit on: http://www.linksys.techssupport247.com or make a call on their toll free
57
Thank you
Hi Lucas,

You can first of all uninstall the linksys easylink advisor through the add remove program under control panel.
Restart your computer. Open Internet Explorer and in the address bar type 192.168.1.1 and press enter.
Click on wireless tab on top. The network mode should be on mixed. Change the ssid to your preferred name. Leave the wireless channel on 6 (some numbers after that). Wireless Broadcast should be enabled. Now click on save settings. (Click on continue if it ask you or wait till the page refreshes back showing the updated settings).
Now below the wireless tab on top click on the sub tab "wireless security". Click on security mode pulll down menu and select WPA PERSONAL. Select the algorithm from TKIP to AES (this will enhance the wireless security of WPA). In the WPA Shared Key type any password consisting of numbers and letters (minimum 8 charachters length and maximum can be 64 charachters...but do not make a very long password that you would not remember). Now click on save settings (follow the same rule).
Now click on "Advanced wireless settings" (fourth and the last one) sub tab on top and change the Beacon Interval from 100 to 75. Change the Fragmentation Threshold from 2346 to 2306. Change the RTS Threshold from 2347 to 2307. Click on Save Settings (follow the same rule).
Unplug the power from the router for 20 secs approximately and power it back up (also known as powercycle).
Check first connecting your computer hardwired to the router's any number port on back (check if the light comes on on the router front panel). if you are able to go online (if not then unplug the power from modem for a minute and power it back and wait for another minute and check the internet connection).
If you are online through wired connection then unplug the cable from your computer to router and keep a minimum of 3 feets of distance between the router and computer (at times when very much the router there is a dead spot for wireless signal) and try connecting wirelessly on your now secured wireless network. when prompted for network key or wpa shared key box then enter your wireless password you had set on router. click on connect and wait till it shows you that you are connected. you can now close down this screen and check through your internet browser by going to different websites and you should be online.....

Hope the above steps help you to connect wirelessly on your secured wireless network.....
I tried your steps and thank u. However, once I disconnect from the router, I lose connection. Now what should I do? Please reply to marilynsoto3@gmail.com..thank u again!!
Got it!!!! Thank u again!! What Verizon couldn't do, u did it in minutes!!! Thanks again!!!
Hey Dolphin, you are a genius. I just bought a replacement router but I found this forum and followed all the steps you have given........it's perfect!! I wish there will be more people like you in this world. Thanks!!!
Don't know why it worked, but it did! Thanks!
You saved me, thank you so very much!
7
Thank you
You must remember that some ISP can read the DHCP server of a router this after 4 computers Most block
after 4.
Workaround:
Set Static IP to each nic past 4 computers is max for most cable ISP.

I started setting static IP past 4 computer upto 22, is all I did because I run out of computer to hook up to the router
Once I went back to DHCP lost connection on all but 4 computers this is hard wired computers.with switch added to the router.
This applys to Cable TV and Hughes Sat. and maybe Comcast I will be testing this next week on Comcast ISP.
Most modern ISP will recive the DHCP log from the router is why you set all nics to Satic .
thankfulforforums - Oct 25, 2008 at 11:09 PM
2
Thank you
The clone feature solved my headache! Thanks a ton! Internet now working again! And yes, I have comcast too.
2
Thank you
I also have to applaud Mark. This solved my very frustrating problem immediately. Wish I came across his advice earlier. Linksys and TimeWarner Cable sites weren't very helpful at all.
1
Thank you
This message board is too funny! I read the whole thing and had to laugh (especially about the guy with a neighbor with unsecure wifi! LOL!!) I'm just glad to know I'm not alone! Believe me -- I feel your pain! I've been going stark raving mad for a solid week trying to get this blessed thing to work. My WRT54G has worked great for 5 years except for a few reboots on occasion, and then suddenly last week everything went haywire and nothing I did would make it work (connecting to Comcast via Motorola surf board). I think my issue was a missing or corrupted driver for the LAN manager. So I was dealing with system issues as well and I'm still not quite sure how I accomplished it, but I'm wireless at last! Found this board waaayyy too late! Not sure if the tips would have helped my driver issues, but maybe it would have at least made me laugh! I've copied all the tips and tricks and saved them - just in case! Thanks everyone!!
1
Thank you
maybe this will help you lucas:

check your ip adress
then release and renew your ip adress
then check for networking wireless on you computer to start working
and finally you can power cycle if needed.

check ip adress:
start menu
run
type cmd; a black screen should appear
type ipconfig

release ip adress:
same process but instead of typing just ipconfig, type ipconfig/release and it will go to zero
then type ipconfig/renew

*you also have the option of realising and then powercycle to reset it.
kdog killa killa - Jan 7, 2010 at 05:50 PM
1
Thank you
I had a similar problem and the solution was simple. I thought I knew the password/key because linksys won't tell you that it is wrong, it will show full signal strength but no connectivity. Turns out the password was just slightly off.
1
Thank you
I fixed my wireless internet connection with a few simple steps.

I connected my modem (comcast) to my wireless router (apple time machine) then connected a ethernet cable from the router to my desk top computer (mac) then connected another ethernet cable from the router to my laptop computer (also a mac). With both computers, router and modem turned on I then reset both modem and router by using a pen to press the tiny reset button on the backside of each devise. After each rebooted a screen appeared on the desk top which walked me through the steps to reset the router. After completing the router reset I then unplugged the power cord from the modem until it completely shut down then plugged the power cord back into the modem restarting it. I then restarted both computers. After the computers restarted I had a wireless connection to my laptop computer.

Keep in mind that you must have the airport utility turned on which you will most likely find at the top right of the screen.

I hope this will help you and others who have searched endlessly for an answer.

FYI: I was receiving messages that said "self assigned ip address" before I came up with the idea to try the steps above, this after trying everything imaginable.

GOOD LUCK!!!!!!!!!!!!
1
Thank you
I am having the same problem with my Linksys router! The guy at RadioShack told me to remove the Linksys program in the control panel then hold the reset button on the back of the router for 1 min. Then reinstall the program. But, I cant find the name "Linksys" or "Cisco" under the Add/Remove Programs menu!! Struggling...
1
Thank you
dont use Linksys eay advisor setup use windows wireless networksetup!
1
Thank you
HELP I DONT HAVE CABLE NO MORE AND I DONT HAVE A MODEM EITHER SO HOW DO CONNECT MY LINKSYS?
johnkwit 4 Posts Monday June 16, 2008Registration date June 17, 2008 Last seen - Jun 17, 2008 at 06:09 PM
0
Thank you
I have a new Linksys router WRT54gs and a new Dell laptop.
The router works well with the cable attached but when I go to wireless
I get a strong signal but unable to get on the internet with WEP security.
With security disabled the wireless works fine. But will not connect to the
internet with WEP security on. I tried to use the CD install disk that comes
with the router but ir does not help.
Any help would be apreciated
Set the secutirty to WPA personal. WEP is the worst for security, as I could hack the password in seconds. This is impossible for WPA.
Vic > Btroisi13 - Apr 27, 2009 at 07:26 PM
I had trouble with my set up, did everything on the set up disk many times. Then, I plugged my Linksys into my Comcast cable box (combination phone & Internet), plugged my computer into the Linksys with everything turned "ON". Then I re-booted the cable modem. In the back of the box is a small hole the size a paper clip fits into and pushed the reset button and I made contact with the Internet. Later I set up my WEP key. Hope this works for you.
Jim > Btroisi13 - Feb 24, 2010 at 04:58 PM
My linksys router died last year and I got a new one. At that time, the linksys rep helped me install my E-machine desktop (XP), my Dell laptop (XP) and my HP notebook (VISTA).

The linksys router seems to be working fine with my these computers. But when I tried to install the HP Officejet Pro 8500 printer/scanner on the HP notebook, it rejects the WEP that I believed I've used in the past. (Just installed the 8500 on the Dell last week and it's working fine. It didn't ask me for the WEP.) The printer says it's the wrong WEP -- but it's the only one I have.

I don't want to reset the whole router security because then I'll be unable for a time to access the web from my computers -- which I need.

Is there some way I can check the WEP to see if I have the right one? Could this be a VISTA problem?

Thanks.
driver audio device on high definition audio bus trouble
Since the wireless is working with unsecured, this might be a problem with router config. You could change the channel, security to WPA. It would work fine...
0
Thank you
I am using this router with Comcast Cable Modem. At first my router was a little bit troublesome to configure, but it was working pretty flawlessly for about 10 days. then it started just dropping the internet signal, both to the hard wired desk top and to the wireless laptops.
I tried holding down the rear reset button which apparently made it lose its "protected status" but it didn't fix the problem of the signal getting dropped.
I have tried unplugging and plugging everything back in. I have NOT tried to re-configure router using disk. Should I try this or just call linksys??
An Anonymous Pseudonym - Sep 10, 2008 at 03:49 PM
I've had users complain that, in the past week(s), they have had increasing problems with their Comcast/Linksys setups, and that this procedure general works out some of the issues:

Flush DNS
Start->Run->cmd
'ipconfig /flushdns'

Power-cycle the router.

I know it seems simple, but this has drastically improved maintaining connection to Comcast via a Linksys router for those in my organization.
Moneluv > An Anonymous Pseudonym - Nov 13, 2008 at 07:37 AM
What do you mean when you say "Power cycle your router"?

My comcast modem works fine. WRT54G all the sudden (after 5 years) just doesn't work. We called Comcast who troubleshot on their end and it works fine through the Ethernet. My roommate has Vista, I have XP. It will show a strong wireless connection but sometimes it won't connect to the internet, and sometimes it will. I've always used it "Unsecured" but tried securing it. Any "layman's" help you can give is Greatly appreciated.

Moneluv
joao meyer > An Anonymous Pseudonym - Feb 28, 2010 at 10:19 AM
Flushing my DNS was what I needed to fix my "Renewing IP Address" error, try doing that.
Amazing. Flushing the DNS worked for me. Thanks.
0
Thank you
Jackie is right. Remember to temporarily disable your wireless network connection on your computer first though, to make sure you are using the ethernet connection (wire) while you are jury rigging (cloning the MAC address of your computer onto the wireless router) the router.

And yes this is because the cable ISPs would like to charge you extra for more than one computer connected to the Internet, since they already have some customers paying extra. But in today's world of so many network connected devices, that is not realistic. So your router disguises itself as your computer. (Somehow on the Cable ISP end it would seem they are able to tell the difference between a computer's and a router's MAC address perhaps.)

And then the router shares the internet connection. You could leave one computer running and share it's connection as well, but that would be a waste of a computer and probably more power use also, which would accomplish the same thing (using a computer as a router,) with the wireless router connected to that computer, which would complicate the setup though.
0
Thank you
I am having the same problem as you guys. I am trashing this router and looking for another. Suggestions?
deadmanwalkin - Jul 5, 2010 at 10:54 AM
0
Thank you
Actually, I have the EXACT same circumstances as you, but I have Vista. After it told me the connection failed, I just hit back, and it said it was successful.
0
Thank you
The Easylink I got with WRT54G seemed fickle at first for me. I believe I found a newer version online. Possibly this manual instruction will help: http://homecommunity.cisco.com/...
0
Thank you
The easiest way to access a linksys router is by typing "192.168.1.1" into your web browser(internet explorer,firefox, etc.) the default usename is to leave the space blank and the password is admin.

And listen to Ryan, hes right.

Amanda: you need to do a "hard restart". you must push the reset button with your router powered on. Hold it for 30 seconds with the router powered on. STILL holding it, pull the power cord for 30 seconds. Still holding it, plug the router back in and continue to hold the reset button for 30 more seconds. You will have held the button for a full 90 seconds without releasing it.

MINNI583: You need a modem to connect the router to to be able to get internet.
rosejulo 1 Posts Thursday January 14, 2016Registration date January 16, 2016 Last seen - Jan 16, 2016 at 09:03 AM
0
Thank you
Good news!
I am Rose contacting you for agent vitar
ventur rosejulo01@gmail.com for more information.
1 2 Next

trouble with Linksys WRT54G router - page 2