Atheros Wireless Adapter won't connect to int

Solved/Closed
yorkiedad - Jul 22, 2009 at 11:42 PM
 Laura - Aug 22, 2010 at 11:34 AM
Hello from Danville, Virginia, USA

I have an Acer Aspire One A0A 150. The Wireless adapter will not connect to the internet, but it does find my wireless network and will connect to it. I have turned off power saving mode as per Acer tech support info. I have turned off all firewalls, and have verified the settings in Windows. I have released and renewed the IP address. I can ping out but get two returns then request timed out. This is consistent. 50% packet loss, two times out, two returns.

I can connect fine with an ethernet cable from my router, I can connect fine with a Belkin USB wireless adapter.
I can connect to the internet with the Belkin from any wireless site. I cannot connect with the built in Atheros adapter. I made sure the Atheros and Belkin adapters and drivers did not conflict. I downloaded and installed the latest Atheros wireless driver for my Acer Aspire one. Still can't connect to the internet.

Does anyone know what to do?

Thanks

Hunter (yes, I live with a yorkie therefore the nickname of Yorkiedad.)
Related:

7 replies

Believe it or not, what fixed my problem is downloading another Acer laptop's model's wireless driver from Acer. I have a second Acer laptop (different model than mine). I noticed it's using the same AR5007EG Atheros wireless adapter as mine but with a different year and driver version number. And it was having no problem surfing. So I downloaded that model's driver from Acer and used it on mine (after uninstalling my adapter completely) and now I can surf. What's funny is that I tried downloading MY acer's wireless driver from Acer and it didn't work. It was the same version I had before. FRUSTRATING on Acer's part!! who would've thought you had to dig the idea up of downloading another laptop's model's wireless driver??? But anyway that's what did it for me. Good luck.
25
Thank you, thank you! I've been trying to fix this problem for weeks and yours was the only solution that worked!
0