VPN Connects but no remote LAN access

Solved/Closed
Redeemer - Feb 10, 2009 at 03:17 PM
 Onkon - Feb 28, 2019 at 08:16 AM
Hello,

This just started happening about two weeks ago. I connect to a client site using Microsoft VPN client (pptp). THis has worked for well over a year until two weeks ago. Now when I try and connect I establish a tunnel but cannot access resources on the remote LAN whether by IP address or UNC, hostname, etc. After about 30 to 60 seconds the tunnel disconnects without error or notification. I have this problem on 3 of my office PCs and also if I try this from my server.

Here's where it gets strange - I have two other PCs in my home office that are on the same LAN as my business machines and they CAN establish a VPN tunnel to my customer's office and ping all devices on the remote LAN! They have the same OS (Windows XP Pro SP3) as the machines that are not successful.

Normally I wouldn't care if I couldn't reach their network remotely as I have other means of connecting, but this client has remote users and the same problem I have has happened to one of their remote users. So now I have to figure it out. I'm not sure what other detail I need to provide. I'm wondering if a new Microsoft patch has had some affect or not.

Some things I have tried:
Removing the VPN connection and adding it again
Run a repair on the NIC
Flush DNS
firewalls are disabled on all machines
unchecked and removed tcpip from NIC. Reinstalled TCPIP.
Rebooted (of course)

6 replies

I had a similar issue... What I had to do was tell the connection to not use the remote gateway to connect through internet.

On the Windows machine :
  • go to the properties of the VPN connection.
  • Click on the Networking tab and double click Internet Protocol Version 4 (TCP/IPv4).
  • Click Advanced and uncheck the box for "Use default gateway on remote network."


This will route all of your local traffic through whatever network you're locally connected to, and any remote traffic through the VPN connection.

This also assumes that you're not trying to route your internet traffic through the VPN. If you leave this option set, then you will not be able to access any local network resources without manually specifiying routes to get to them. This is the default design of VPN :D.

I know this post is old, but I figured I'd put in what I discovered it to be, maybe it can help somebody down the road.
228
Cadbomb,

How do you get to these settings if you don't actually have a VPN connection configured? I am using a Cisco VPN connection and am able to VPN when I am connected to my land line connection at home. But when I disconnect and go wireless, I have the same problem that everyone has mentioned here. My LAN connection doesn't have the same Advanced options as you mention.

Thanks.
0
I have the same problem and I connect to the VPN but cannot route traffic or see any remote resources ... the attribute you suggest to change on the VPN connection doesn't exist for me. Any other ideas?
0
Any idea how to make these exact same changes on MacOSX?
0
no idea for mac. for the VPN connection you should be changing the VPN connections properties. not your network properties ! especially if they were working - and you could "surf the net"...
ps I had this same issue on 2 computers, cadbomb's solution for the gateway fixed this one, and the other one will be when I get to take another look at it.
0
Delayed response, I forgot I even posted this in here, but for Cisco you need to go to the properties of the VPN profile you connect to and click the Transport tab. The check the Allow Local LAN Access box. Does the same thing as the option before. As far as for Mac, I'm not too familiar, but there should probably be an option similar somewhere in the ip settings.
0