Pen drive is detected but not accessible [Solved/Closed]

- - Latest reply:  Taofik - Mar 25, 2013 at 08:00 AM
Hello,
my name is christu I got a sony 4 gb pen drive at first it worked properly on my system. But after few days when I insert any pen drive in to my system usb port it asking me to insert in to the H: drive....But my system has all the new configuration so please help me..
See more 

2 replies

Best answer
Posts
1
Registration date
Monday February 18, 2013
Last seen
February 18, 2013
10
Thank you
SITUATION: USB recognized but not accessible.
- The files and folder are corrupted and cannot be opened
- The right click is not working
- The Windows Disk Management is not working (make a try first!)

SOLUTION: Use a tool to resize the partition, make it a little smaller and after that make it back bigger to original size.
May work with other tools too, but I did it with
GParted
http://gparted.sourceforge.net/livecd.php
.
If you have a Linux Live CD or installation you have GParted in the system menu.
GParted resize will rewrite the partition table and you have the chance to get a working usb stick with all the data.

This way is better and you should try it before to format the usb drive, because after format you need to recover files with other software and is another pain .i.t.a.

Thank you, prezent 10

A few words of thanks would be greatly appreciated. Add comment

CCM has helped 2576 users this month

Posts
336
Registration date
Wednesday May 13, 2009
Last seen
October 27, 2009
4
Thank you
Dear Christu,

This is a very common problems which users always go through!

All you will have to do is to format the pen drive,

I will advise you using a formatting tool!

Please download it here:

http://ccm.net/download/download-127-hp-usb-disk-storage-format-tool

Install and then run to format your pen drive

Thanks
ya its true that I should format but my pen drive is detecting in another computer,i am facing this problem in my computer itself what to do.I formatted it in my friends system like "right click format" not with any special tool.It is succfully formating.
I don't know how to thank you..my problem solved man...
THANK YOU very much
IT really paid of after 1 year.
I also used this software and it worked pretty well for me
Thank you ............................