Damn toshiba satellite

Closed
mgeeze - Oct 11, 2009 at 05:55 PM
 jfadams - Mar 28, 2013 at 08:09 PM
Hello,
i have the toshiba satellite, I left it on for the afternoon...i came back and plugged it in..now it will not turn on..
all i get is the orange light..when i try to turn it on, i get three lights that come on..the F10, F11 and Caps lock light..
Help, any information is welcome..
Thanks in advance

5 replies

Blocked Profile
Oct 12, 2009 at 01:55 AM
Dear Mgeeze,

Could you please let it charge over some time

and turn it on. This could be because of

exhausted battery.

Thanks.
0
thanks for your reply louissteph, its still not charging..nothing happening..
its been charging for the past 24 hrs...any other suggestions..i welcome it..dont want to lose the information on the laptop..

thanks again:)
0
Blocked Profile
Oct 14, 2009 at 08:12 AM
Dear Sir,

Could you check charging with another cable please.

It could be that there is no electricity passing through the cable,

Thank you.
0
Having a similar problem. Did you solve it. Would be grateful to know.
0
Have same problem. I found this thread by googling toshiba satellite caps lock light f10 f11 Any known solution?
0

Didn't find the answer you are looking for?

Ask a question
Had this same problem - solved it by removing the battery and unplugging the power cord, followed by holding down power button for 30 seconds.

Afterwards, put the battery back in and plug it back in, hopefully it should work.
0