USB Storage Device is

Closed
SilentLetters - Nov 2, 2009 at 02:46 PM
 SilentLetters - Nov 6, 2009 at 04:13 PM
I am going to try to be as rigorous as possbile to explain the situation, to avoid hearing "solutions" that I have heard before. First, the process:

I have a USB flash drive, 32 GB (THE FILES ON IT ARE NOT IMPORTANT, I DO NOT NEED TO "RECOVER")

other USB flash drives work.

I plug this one into the USB port (the usb port is working corectly, the flash drive's light is on)

my computer informs me that it is installing drivers for the plugged in hardware
problem: the driver is called 'unkown device' which now brands my 32GB as nothing, basically.

because it is branded unknown, it does NOT show up as a drive (in the eyes of the computer, my flash drive is a meaningless void), meaning I cannot interact with it meaningfully, like formatting it, changing drive paths, partitioning etc.

I tried installing the generic USB Mass Storage Device driver onto it, but was halted, being told the device would not start, although it did then show in device manager as a "USB Mass Storage Device", but with a yellow triangle exclamation (most likely just that it was named it but not treated as such, since taking it own and plugging it in here or anywhere once again sees it as the 'unknown device' and installs drivers for it as one)

Here is why I don't believe it is broken:

1. it is solid metal. It would not have broken from anything I could've dished out.
2. it fluked once, when I first gained this problem as a zero size drive, and I haven't done anything to it since.

So again, to run down the list of solutions that don't work/apply:

checking physical (or magnetic) damage
checking if other drives also work
checking if usb works (light is on)
checking if usb port works
checking for drive letter mix up
trying to format the flash drive
trying to partition
any form of interaction along the lines of disk management
attempt to install driver (only labels it as a drive, but doesn't treat it as one)
plugging it into other computers and trying any of the above
if I missed anything that I have tried, I'm sure people will make sure to mention it as if it is the holy grail.
Related:

4 responses

xpcman Posts 19530 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,825
Nov 2, 2009 at 09:27 PM
Did you try the HP formatting program?

https://ccm.net/downloads/tools/4639-hp-usb-disk-storage-format-tool/

Good Luck
0
SilentLetters
Nov 3, 2009 at 12:28 AM
I got home, was excited to see there was a reply, downloaded the program, brought up it's window...


It did nothing, it did not recognize the USB flash drive as a drive (like everything else I mentioned)

It DID however recognize my USB Terrabyte portable hard drive. But that's not an issue.

Still waiting I guess.
0
SilentLetters
Nov 3, 2009 at 11:52 AM
Well, after what happened this morning, I know it's not damaged at all, the USB was plugged into my laptop, and after turning it on and logging in, I noticed the "safely remove hardware" button was on. I checked it, and along with my 1TB hard drive, there was the flash drive. it was there with everything on it. I "safely removed it" to see if it had become resolved, and now it's back to the same as before...
0
SilentLetters Posts 1 Registration date Tuesday November 3, 2009 Status Member Last seen November 4, 2009
Nov 4, 2009 at 01:29 PM
update: after a while of tinkering with the forced-driver idea I got it to work in USB 1.1 slots, even though the computer would still define it as USB 2.0

I'm not even so sure anyone is reading this.

either way, I tried getting it formatted, but it acted as if it was write protected. After using killdisk to try and wipe it clean, it is now treated as a removeable drive (like a floppy disk, or a card slot)

does anyone have a method of virtually inserting media into it temporarily and then use a program to re-image it as a flash drive?
0
SilentLetters
Nov 6, 2009 at 04:13 PM
does no one have advice on mounting media onto this "removeable drive" and then wiping it?
0