'USB malfunction' please help!

Closed
xXMandiXx - Jan 29, 2010 at 07:51 PM
 xXMandiXx - Jan 29, 2010 at 08:36 PM
Hello,
Well, I have an Acer Aspire 5315-2580 laptop, with windows vista home premium. the other day, I plugged in my USB card to my wireless mouse, and a small information bax popped up and said that there was a malfunction, and windows did not recognize the device. Does anyone know how to solve this? I don't want to get a new mouse because I've heard so many success stories through research, though i've tried many theories that have worked for others but don't seem to be working for me. I've done a system restore, restarted my computer, unplugging the USB card and plugging it in again, and taking the battery out. None of these methods have worked. Please help me?

~Thanks in advance all you awesomesauce people,~
xXMandiXx

2 replies

rizvisa1 Posts 4479 Registration date Thursday January 28, 2010 Status Contributor Last seen May 5, 2022 768
Jan 29, 2010 at 08:17 PM
Ok this would sound real stupid, but have you tested your mouse in some other laptop to ensure mouse is ok and also tested the USB port.
0
yup, the mouse is in working order, so is it's card, I may have not checked the USB port, but other devices work just fine in it, so I presume it's fine too. It only seems to be the mouse :/

~Thanks in advance~
xXMandiXx
0