Cannot browse - ftp ok, email ok, ping ok [Solved/Closed]

justabouthangingon - Oct 14, 2008 at 03:27 PM - Latest reply:  2NinerRomeo
- Jun 14, 2015 at 07:11 PM
Hello,


I have been following the thread from people with similar problems but mine is not fixed. This all happened yesterday when AVG falsely identified Zone Alarm as a Trojan and the 'Resident Shield' collected 350,000 examples as Zone Alarm ran all night. I uninstalled both AVG and Zone alarm but since then I am unable to browse the internet for longer than a few minutes. A reboot then restores access for a few minutes.

I have tried everything. I can access email and ftp. I can ping to URL and IP but cannot browse to either (therefore not DNS?) I have tried to fix with winsockxpfix but no effect. Have used netsh reset winsock catalogue no effect.

The effect occurs on different networks. I am using XP + SP2. Have used SP2 winsock fix also.

Could it be TCP/IP stack? Or corruptred browser? Tried system restore - no use.

Am losing the will to live.
See more 

24 replies

Best answer
rsskataloget.dk - Jun 23, 2009 at 02:57 AM
34
Thank you
Hi All,

Had the same problem... Firefox seemed to work, not Chrome nor IE.
In IE I went under Tools->Internet Options->Connections Tab->Lan Settings
Removed check mark next to Use a proxy server...
Put check mark next to Automatic ...

Regards
Johnny A. Escherich
rsskataloget.dk
Danske RSS Feeds

Thank you, rsskataloget.dk 34

Something to say? Add comment

CCM has helped 1695 users this month

Indeed, if only one browser does not work, but the others do, it looks like a wrong browser setting. Wrong proxy settings are one of the most likely candidates then. But in our case, no browser works, so this is very unlikely. To me this looks much more like a problem in the IP socket.
Turning off the proxy setting (which was turned on by some malware) fixed my connectivity problem, THANKS!!!
ditto for me!!
Me too - thank you so much for helping me to get this RESOLVED!
Man that worked for me too - Very greateful, Thank you.
xpcman 19103 Posts Wednesday October 8, 2008Registration dateContributorStatus July 17, 2018 Last seen - Oct 14, 2008 at 03:50 PM
8
Thank you
Here are a few more things you can try. They might help :)



click on start, run, enter 'services.msc'

look for DHCP client....
if it says acquiring network address that means that the dhcp client is DISABLED OR STOPTED... highlight the DHCP client and on the left side you will see "START" the service, click on it and then it will say "STOP, RESTART" then double click on the service and on the startup type select automatic, apply

Symptom
DHCP Client Service may not start automatically. When you attempt to start the Service manually, the following error may be displayed:

Error: Could not start the DHCP Client Service on local computer
Error 1068: The dependency service or group failed to start.

Resolution
The DHCP Client Service in Windows XP, depends on these three components:
* AFD
* NetBios over Tcpip
* TCP/IP Protocol Driver

If one of the above drivers fail to start, then the DHCP Client Service may not start.
Step I - Make sure that the three driver files are present

Open Windows Explorer and navigate to /Windir/System32Drivers folder. Make sure that the following files are present in the folder:

* afd.sys
* tcpip.sys
* netbt.sys

If one or more of the above driver files are missing, extract them from the Windows XP CD-ROM or from the ServicePackFilesi386 folder, whichever is the latest version.

Step II - Verify the number of Dependencies

From other sources in the Web, I've found that some versions of Norton Antivirus (NAV) adds an entry to the DHCP Service Dependencies, and removing NAV does not remove the appropriate value from the DHCP Dependencies.

To quickly determine the Dependency services for DHCP Client Service, type the following command in Start, Run dialog:

CMD /K SC QC DHCP

Verify the output. It should be exactly as below:

[SC] GetServiceConfig SUCCESS

SERVICE_NAME: dhcp
TYPE : 20 WIN32_SHARE_PROCESS
START_TYPE : 2 AUTO_START
ERROR_CONTROL : 1 NORMAL
BINARY_PATH_NAME : C:WINDOWSsystem32svchost.exe -k netsvcs
LOAD_ORDER_GROUP : TDI
TAG : 0
DISPLAY_NAME : DHCP Client
DEPENDENCIES : Tcpip
: Afd
: NetBT
SERVICE_START_NAME : LocalSystem

If additional entries are listed under DEPENDENCIES...
If any other additional drivers or Services are mentioned in the DEPENDENCIES section, you need to remove them via the registry. Follow these steps:

* Click Start, Run and type Regedit.exe
* Navigate to the following branch:
* Backup the branch to a REG file

HKEY_LOCAL_MACHINE SYSTEM CurrentControlSet Services Dhcp

* Double-click DependOnService MULTI_SZ value and set it's data as follows:

Tcpip
Afd
NetBT

* Close Regedit.exe

Step III - Verify that the Dependency Service / components are running

Next step is to verify that the three dependency components are running. As the three components are actually the Kernel Drivers (Driver Service), you need to manage then via the Device Manager. Follow these steps:

* Click Start, Run and type DEVMGMT.MSC
* In the View menu, click Show hidden devices
* Double-click Non-Plug and Play drivers section
* Double-click the entry - AFD Networking Support Environment, and click the Driver tab
* Set the Startup type to System.
* Start the service. Note down the error message if any.
* Similarly start the two other drivers namely:

* TCP/IP Protocol Driver
* NetBios over Tcpip

* Close Device Manager and restart Windows.
padrescout > RolloM - Jan 11, 2009 at 03:32 PM
I had the exact saem problem, non DNS internet burn-down. I could do windows updates and ping through everything just fine but Mozilla, IE, and Chrome all reported no connectivity. Try reseting your tubes:


netsh winsock reset




^ run that command in either run box or command line (should work either way). It may want you to reboot afterwards, but this will get you going. maybe.
RolloM > padrescout - Jan 12, 2009 at 02:55 AM
Thanks for your answer, I did a complete restore of the system in the meantime. Took me just four hours... but now I'm fine again. Next time I'll do this reset. Wasn't the first time I had this problem...

R.
ctrebel > padrescout - Jan 25, 2009 at 07:39 PM
Hi scout, unfortunately that didn't fix my prob, HP says it is a bad browser but i've tried reinstalling ie7 and also installed firefox without any luck. I can download updates and ping sites from the command line but cannot see ANY web pages at all. Almost ready to make a boat achor out of it LOL. Any tips will be greatly appreciated.
Ron
Rich > padrescout - Sep 8, 2009 at 09:58 AM
I was able to ping www.google.com but both the IE and Firefox browsers failed to bring up any url. In addition, any automatic update processes (i.e. microsoft/AVG) also failed.
As suggested I type in "netsh winsock reset" at the command promt and this fixed the problem.

Thank you.

Rich
Same for me. Norton was blocking the internet for some reason. It was a pain in A** to uninstall but I downloaded a patch to assist in the uninstall and it worked.
5
Thank you
if u have tried all things then u try this for once


start> control panel> admin. tools> and dns


stop dns service and restart ur system

and check if the net is working.
Thanks its working for me !
Dns client services located services.msc not control panel
same scenario - avg w/ zone alarm - screwed up my pc! removed proxy setting - works fine...
Stoping and starting it did nothing, but for some reason stopping and rebooting did the trick. Gold star and an upvote for asif.
4
Thank you
I had this problem. It turns out that I had blocked an AVG program with Zonealarm.

I think it was "AVG Network Scanner Service"

Unblocking it fixed it right away.
3
Thank you
I had a similar problem
I was able to get back to browsing on IE and Mozilla Firefox by turning off AVG's Link Scanner

I have not determined how to browse with the link scanner on
1
Thank you
check for the internet explorer 8 version and remove that can solve.