Windows XP Pro CHKDSK Hangs

[Closed]
Report
-
 simba -
Hello,

Yesterday, I attempted to run the chkdsk utility. The message I got was that it will start at my next reboot, I said OK.

I rebooted and the chkdsk started just fine, ran through steps 1 through 96% of 5 and stopped, which is the verifying free space step. So, I rebooted by turning off my computer and turning back on because during the chkdsk process, my keyboard is disabled. Again, chkdsk started running and again stopped on step 5 with only 4% left to go. The system isn't running at that point, no flashing lights, but I still gave it a few hours to work itself out. Finally called Dell support and the only suggestion that guy had for me was a system restore. I didn't trust his advice because he didn't know Windows well enough to use that suggestion. I restarted by PC at least 8 times trying to get the last 4% of step 5, verifying free space.

Here's the real aggravating part. It will start and hang every time I restart my PC. I can't use my keyboard to stop it and move on.

I have recently run the defrag, it was just fine. From the utility menu pre boot, I checked the hard drive and it passed.

I was prompted to run these programs because I recently upgraded to Adobe Lightroom 2 and Photoshop CS4. Those programs shut down due to system errors all the time so I thought it might help to clear up any performance issues.

It would be great if someone has experienced this and worked it out would be kind enough to help.

6 replies

I'm not sure if this is where I should post this, but I am having a problem with chkdsk also. It runs just fine, then I get a screen that says:

checking file system on c:
the type of the file system is NTFS
the volume is clean.
windows has finished checking the disk.
...

then nothing. I can't do anything, cant get out of that screen. I finally tried turning off the power and rebooting using last known and I got a blank screen. Then I tried safe mode and a bunch of junk scrolled down the screen and it froze again. Tried to start normally and just runs the chkdsk again. help
7
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month

I have exactly your problem warnbb
And I was SO PLEASED it found all those errors, I thought everything would be good :-(
Did you find a way out?
I'm also having this problem
.. on a Panasonic Toughbook .. so no CD or floppy drives to help out.

Am basically stuck on the "windows has finished checking the disk." screen

Can't fire up the system at all
OK

Found that if I could press F8 to catch the system after the bios loading (but before the windows startup graphic) then push F8 again to get a full list of windows startup options (on a DOS-looking text screen) I could get windows to start normally by choosing "last known good system" (or some such thing).

Seemed to work for me anyways :)
I had the same problem as warnbb:

checking file system on c:
the type of the file system is NTFS
the volume is clean.
windows has finished checking the disk.

My system stopped on Mup.sys when I tryed the Safe Mode.

The F8 + F8 then Last Known Good option worked for me too.

Thank you PeterB!
hi I just had the same problem, what did u do in the end to fix it?
Sorry you're having the same problem. If you are unable to get out of the chkdsk, as I was, the only thing I could do was reinstall the operating system. I'm sorry I don't have better news for you. I saved everything on my hard drive to a new drive then reinstalled windows scratch. That's the last thing I wanted to do because that involves reinstalling all of the programs and losing all of the personal settings for the programs. Good luck.
Posts
164
Registration date
Tuesday September 30, 2008
Status
Member
Last seen
February 3, 2009
102
I'd take on Dell's suggestion if your still having problems with your chkdisc. Run a system's restore point back to the day before your program problems started. Don't worry about the programs you recently installed or upgraded. You can always get them back. A word of advise.......try not to reboot your PC as constant as you do because you can cause it to crash...............Good Luck!!!!!!!!!!
Hi ,
Solution No: 01
The major problem that why CHKDSK fails to run properly after rebooting because it is not able to get a lock on that volume , you might get a message saying the "Unable to lock volume (somehting like that)" ,
this is a known issue and it happens only when some other application gets a lock on that volume and doesnt allow CHKDSK to take a lock on the same .
This kind of activity is generally shown by AntiVirus , AntiSpyware and Firewall Programms ,
So instead of formatting your whole system , you will just try to uninstall any such kind of application and try running CHKDSK

Solution No: 02
You can modify the BOOT.ini file with the /SAFEBOOT option and parallely make the necessary changes in the
BOOT.INI tab of MSCONFIG utility to let ur system load the minimal number of Drivers when it reboots and you can also specify the list of drivers,So next time on rebooting if you are Lucky :) , u wont get a LOCK conflict and the CHKDSK would run fine ( cause it would be able to get a lock on that volume)

Hope this helps
***********************************
~Abhi
I also have trouble with chkdsk on an usb-drive.
I know that there is something wrong with it, so I try to use chkdsk to repair it.

I do as follows:
start -> run -> cmd
(dos- window)
chkdsk G: /X /F /R

G: the usb-disk
/X = dismounting volume, only chkdsk have access
/F = repair if errors
/R = Repair bad sectors, make readable info (NTFS)

This seems to be working for me, ... it is still not finished 500GB takes a while, but I can work on as normal doing other things that does not involve the g-disk.

If it is your systemdisk that is your problem, then you should hit F8 at startup, choose start from the promt and give the chkdsk command.
If that does not help, download the disk utilities for your spesific disk from the producer and do a health check.
(WinDLG from WESTERN DIGITAL seems to be working well on disks from other producers as well if you cannot find anything useful from your own producer.)
Dude, you are the best!!! F8 and last good config worked!! Many many thanks :-)

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!