Vista randomly shut off & won't turn back on [Closed]

Report
-
 Sapph -
Hello,


Here's the computer information:
Windows Vista Home Premium - Service Pack 1
Manufacturer: Dell
Model: Studio 540
Rating: 1.0 Windows Experience Index: Unrated
Processor: Intel(R) Core(TM)2 Quad CPU Q8200 @ 2.33GHz 2.34 GHz
Memory(RAM): 8.00GB
System type: 64-bit Operating System

All of this is from this screenshot I saved a couple months ago: http://wickzwackz.webs.com/Comp%20Info.jpg

Also, I don't know if it mentions it, but it's a 1.4 Terabyte hard-drive.


My Vista recently shut off by itself and it won't turn on now. I at first thought maybe the location it was plugged in at was bad, so I changed the location several times and still nothing with each try. I even switched plug-in cords thinking that the current one went bad or something, still nothing even with switching plug in locations with the new cord. It's really itching at my nerves because it's my top notch computer I play games and do everything else on. Think you could recommend something else for me to do, or is it absolutely necessary that I send it into a repair shop?

I'm also worrying that a terrible thunder storm might of caused some issues, as well. I know it knocked out the power, and I always leave my computer on. Think this may have done anything?

1 reply

Posts
19566
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
June 15, 2019
1,692
I fear you may have had a power spike that killed either the power supply or the motherboard. Did you have a surge protector ? Such a high end PC needs a high end surge protector.

Good Luck
1
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month

I'm not sure, but it confuses me because I was fooling around on it for an hour or so before it just randomly shut off.

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!