Keyboard and mouse lock up on welcome screen

Registration date
Monday June 28, 2010
Last seen
June 28, 2010
Every time I turn on my Acer TravelMate5520 the keyboard and mouse lock up on the welcome screen. I tried hitting F2 to bring up the SETUP menu before the welcome screen and the keyboard and mouse work fine. after I exit the SETUP menu and go to the welcome screen, the keyboard and mouse lock up so I cant put in my password or move the mouse.
can anyone help me!? plz and thnx!

19 replies

Keyboard lockup during windows login

Cause: After I have uninstalled PCtools Threat fire, firewall, pc doctor in the safe mode. And I have choose to delete related files. And these began…

1st Problems facing:
1) Cannot key in password in logon screen
2) Only can delete the logon password using Boot disk, but CD rom was not function
1st problem’s solution:
1) Using HP tools Windows-based Format Utility for HP Drive Key or DiskOnKey USB (HP 所开发的USB 随身碟格式化程式) to format the pendrive to boot sector and treat as a startup boot disk. The program is: SP27608.exe VERSION: 2.1.8 Rev. A.
2) Then Admin help me to download the boot up system file (Dos format) to view the files in NTfs (??) format
3) Then by key in a fews commands that I dun noe, the password have bee deleted, and now can log into the PC without password key in needed.

2nd Problem facing:
1) After log in windows, No Lan/wireless Network was detected.
2) I try to see whether is network interface card problem or my own seeting problem. And I opened cmd and : ping to see whether loop back action for nic card is ok, but it return: Unable too initialize windows sockets interface, error code 0.
3) Then I google using the problem Microsoft msdn page, it said is the winsock and winsock2 corruption:
4) Click Start, and then click Run.
5) In the Open box, type regedit, and then click OK.
6) In Registry Editor, locate the following keys, right-click each key, and then click Delete:
7) When you are prompted to confirm the deletion, click Yes.
Note Restart the computer after you delete the Winsock keys. Doing so causes the Windows XP operating system to create new shell entries for those two keys. If you do not restart the computer after you delete the Winsock keys, the next step does not work correctly.

And after delete you go run:Msinfo32, Then under protocol should be empty.

Then I need to reset my TCP/IP, since they are corrupted too.
This is what I do follow this link:

In Windows XP, a reset command is available in the IP context of the NetShell utility. Follow these steps to use the reset command to reset TCP/IP manually:
1. To open a command prompt, click Start and then click Run. Copy and paste (or type) the following command in the Open box and then press ENTER:
2. At the command prompt, copy and paste (or type) the following command and then press ENTER:
netsh int ip reset c:\resetlog.txt
Note If you do not want to specify a directory path for the log file, use the following command:
netsh int ip reset resetlog.txt
When you run the reset command, it rewrites two registry keys that are used by TCP/IP. This has the same result as removing and reinstalling the protocol. The reset command rewrites the following two registry keys:

To run the manual command successfully, you must specify a file name for the log, in which the actions that netsh takes will be recorded. When you run the manual command, TCP/IP is reset and the actions that were taken are recorded in the log file, known as resetlog.txt in this article.

The first example, c:\resetlog.txt, creates a path where the log will reside. The second example, resetlog.txt, creates the log file in the current directory. In either case, if the specified log file already exists, the new log will be appended to the end of the existing file.

Then reinstall TCP/IP:

Step 2: Install TCP/IP
1. Right-click the network connection, and then click Properties.
2. Click Install.
3. Click Protocol, and then click Add.
4. Click Have Disk.
5. Type C:\Windows\inf, and then click OK.
6. On the list of available protocols, click Internet Protocol (TCP/IP), and then click OK.

If Internet Protocol (TCP/IP) does not appear, follow these steps:
a. Click Start, and then click Search.
b. In the Search Companion pane, click More advanced options.
c. Click to select the following three check boxes:
 Search system folders
 Search hidden files and folders
 Search subfolders
d. In the All or part of the file name box, type nettcpip.inf, and then click Search.
e. In the results pane, right-click Nettcpip.inf, and then click Install.
7. Restart the computer.
Actually is winsock2 corruption, and first step to do is delete the corrupted winsock and winsock2 registry key and reboot, to let windows to self create new entries for this two. Now can detect wireless., but cannot access to anywebpage. Actually, no need to reset using netsh command, just install TCP/IP and restart ur PC. Now can visit website.

3rd Problem facing:
1) Keyboard not function at all, device manager said driver files corrupted and error code 39 for windows, have tried out uninstall, install the new driver, also cannot work
2) Search on this website:

Manual fix:
Note: Obviously, you probably can’t type as instructed in some of the steps below. Try using your mouse to copy and paste what you need to type from this post to the field it needs to be typed into.
1. Go to your Start menu and click “Run…”
2. In the Run box that opens, type “regedit” and press Enter.
3. In the new window that opens, click the “Edit” menu, then “Find.”
4. In the find filed, type “kbdclass” and press enter.
5. The registry editor will now search for any key that has “kbdclass” in it. What you are looking for is any that have a name of “UpperFilters” and a data of ” something_random_here kbdclass” You may need to go to “Edit,” “Find Next” if the search finds something else first.
6. Once you find the key, double click on it, and edit the text so that it includes only “kbdclass”. Press OK.

7. Continue searching (using the “Edit” and “Find Next” menu) until you have found and edited all of the “UpperFilters” keys. Again, all should have a data filed that includes only “kbdclass”.
8. Close the registry editor.
9. Go to the device manager, find your keyboard in the list (which should still be reporting a “Code 39″ error), and uninstall it.
10. You should then restart your computer, and with any luck, your keyboard will work upon rebooting.
If that doesn’t work, your keyboard may be physically damaged, or the drivers on your computer may actually be corrupt.

Before I edit the name of this value, is shown something like TfRmon kbdclass

Note:Before this problem been solved, I used to get a usb keyboard and try to make it work, but it also cannot detect the HID( Human interface device). But after this problem been solved, the usb keyboard wooork well.

Basically, must key in a correct phrase to find the related solutions in googles. I have key in this to find the website which provided correct solution: windows cannot load the device driver for keyboard.

Note: always export ur registry before modify.
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2821 users have said thank you to us this month

Pls come to Luo yang Henan provoince in China, if you feel my solutions is usefulness
my problem is when I run the windows xp pro on my plaptop it blocks the keyboard and touchpad. but when I login with safe mode it is perfectly fine secondly when I put my laptop on system virus scan with virus protection software keyboard and touchpad starts working normally ...... I think this is a virus that causing the problem sugest me the solution......................

Hi, Amit, my India fren, hope you have already resolved this issue. Your analysis sound is correct, this should caused by a virus. Any way, could you post up the virus name that your anitirus have detected? also your antivirus name, hope your way to solve can help more member in this intenet virtual world communites. Thanks a ton.
The battery thing was right on for the Acer Aspire 3000 I was working on, I noticed that using the machine in safe mode the keyboard and mouse functioned normally, and they work off and on in normal mode, but 89% off as opposed to on. When taking the panel off the bottom, because of the heat of the unit I noticed the North Bridge was extremely hot, blew out cpu fan and made sure the venting was all clear, but it would get extremely hot and I could plug in a USB Keyboard and Mouse, they would work, but the unit would not shut down (sysfader not responding). Brand NEW hard drive and fresh load. (so don't say this one's virus). Took out the battery and Voila! no problems... anymore at all. The machine is trying to charge this battery and is building up a bunch of resistance, the battery at full charge is down in 2 to 3 mins. so it's a dead cell ... or the electronics in the battery are messed up, either way the machine litterally heats up the north bridge until it is extremely hot and the keyboard and mouse just quit working properly... they're still there... just not working properly ... test it, when your mouse isn't working, give it a bit of a "tap" the mouse pointer jumps >>> ! For most just pull the battery and that will work, if that is successful then try out a new battery. Thanks for the poster(s) who helped.
Thanks, had the same problem and took out the battery and all worked ok
Worked here too with an Acer Aspire 3000. Mouse or keyboard wouldn't work at all in normal mode but worked just fine in safe mode - also worked in a live CD of Fedora. I noticed that whenever the machine would shut down the power manager app built into windows would hang and you had to forcefully end it for the machine to shut down. Battery life also was in the range of a few minutes on a full charge.

Thanks elvis4949 - you saved the day!
Registration date
Friday May 28, 2010
Last seen
May 28, 2010

After one year searching for a solution ... I got it. ACER Aspire 5620, dead battery, I removed the battery and it started to work normally. THANKS ELVIS4949.
Registration date
Monday June 28, 2010
Last seen
June 28, 2010

Elvis this worked for me too. Can I ask what you mean by "the north bridge"
Registration date
Thursday February 26, 2009
Last seen
March 1, 2009

May be touchpad is locked? Can U press FN+F7 keys to unlock touchpad?
guya remove your battery and see if it helps the problem remove battery then restart system
Registration date
Monday June 28, 2010
Last seen
June 28, 2010

dman I worship at your feet Thanx Thanx Thanx
My father has this same trouble on his laptop and I am searching any and all forums for a resolution. Im not sure you found your answer yet ..if you have would you mind providing me with some details..thank you
I'll tell you what's the's tha nastiest virus ever :).....i called for a squad to fix the problem :)
> Dimitar
Ya that sucks...grr do you know the name of the virus? I have some tools to rid it.. btw thanks for the speedy response!
> Conrad
naaah,i don't have an idea,some silvervirus or smtgh I really don't know ....but it's sure the ugliest virus ever :)
Registration date
Tuesday May 12, 2009
Last seen
May 13, 2009

I'm having a similar issue with my wife's computer. She has a Dell 8200 Dimension.

today I was working on the 2 CD ROM drives, one is a master, and the second is a slave.

After I closed it up and hooked all the wiring. The Mouse & Keyboard (both are plugged into the mouse & keyboard ports (not the USB) during boot they both lock up at the Welcome.
Simple solution here guys.
One Unplug your mouse and plug it into another port.
Two Sleep your computer.
Three Unplug your Keyboard plus it into a new port as quickly as possible(as this action will take your computer out of sleep mode)
Four Tap your key board
Five Mouse should work Keyboard is varied.
I hope this helps and I didnt realise this was a virus lol if it is its a pretty shit one.
I will find it tonight and delete it xD.
Also quick question does anyone know how to get ontoa passworded Vista computer without deleting any files or resetting the password? This would be great help.
NEVER ACCEPT A .BAT file this is mainly it.
Other possiblitys is if you download porn you aint paying for as its a backup to (get your own back)
Hope this helps
Anyone got a solution yet? I have same problem.
Started when I replaced my mouse and keyboard to other ones (in win2k)

Will's solution doesn't work, since I can't get in sleep mode because mouse and keyboard don't work.
F**K I have the same problem too....did u fixed it? what should I do?! I think it's a virus :S
Interesting topic, 1st I came accross while googling my laptop problem. Here are my thoughts on it.
The last two posts are on the right track, I don't think its a virus as scanned with a few and this is a clean install.
My laptop was overheating as just shutting down because of it, I found I've had to run it while stuck on a few cd cases to allow air to circulate round the bottom, which is pretty dire.
What was worse was that I'd not been using the battery as didn't want to keep charging while on the mains.
Low and behold as soon as it booted the mouse pointer kept shuddering around the screen, when it did eventually get to the desktop, it kept locking up while perhaps moving every couple of mins.
After switching off and removing battery there was no problem, insert the battery and the problem returned.
I don't really understand whats causing the battery problem, and I'm still lokking for the answer.
I think from bit more reading, it may be bios related. Its got something to do with the power mangerment.
It's a realy poor show, I wish I'd never bought ACER in the first place. I've contacted ACER about two weeks ago, and I'm still waiting for a reply although I don't hold out my hope.
What I've read and about to try is going into the bois and disabling any ACPI stuff, if that doesn't work I'm going to flash the bios (Kill or cure is my approach).
Hope this shed a little more light on the problem.
The lesson to be learnt from this I think is don't buy anything ACER again.

I have also the same problem :

in save mode: keyboard and mousepad are ok
normal mode: as good as not working( in the beginning there was some movement, but nothing normal...)

when I use an external usb keyboard and mouse: works fine, but not always because sometime the system (windows xp home (fresh recovery form the hidden diskrecovery) starts but not normal (slow?) so I cannot do anything, ... have to reboot.

when I take the battery out: works great!

strange things happening here

and gets which laptop? ACER!! aspire 3000.
win xp SP2, fresh install, everything is original.

Did Acer answered you question ?? (to Don'tBuyAcer)

I also have Acer laptop....ans was facing the same problem and spent 2 days trying different things....And here you go....removed the battery and it works perfect...thanks to all those who provided the solution...
computer worked fine last evening... this morning the mouse has disappeared and nothing works properly. Any ideas WHY and what can be done?
One suggestion I can say is that within the control panel, use the tab key to get to Ease of Access Center. hit enter and tab to the "Start On Screen Keyboard" this will provide the keyboard (I'm using Vista). But I also have the mouse usage. Without a mouse, use the space bar to place X in box for keyboard access.

My other pc is sitting without a true functioning keyboard. So, I am real familiar with this on screen keyboard
feature and even made a shortcut in the quick launch. If so desired, one can even change the font on the keyboard.

My mouse and keyboard are wireless. Anyone with the name of the virus? I new it was a real blister. The creator
of it has some serious emotional issues since most Virii are easily correctable. This crippling virus almost had me
in tears since I had a 2 gig file that I hadn't backed up. I was sad that my fantastic game scores would be trashed and honestly felt so sad as if I lost a great friend (as I was facing the thought of complete disk deletion). Insane, huh? But I hung in and it took almost 2 days to make minor teency weency advances. I still have it on the one system but I got the 2 gig file off. I have lowered my expectations to just using the on screen keyboard until an answer surfaces.
The ACER bios is rubbish and causes weird things to happen if the battery isn't 100%. Try booting the laptop up with the battery removed. My top tip is never by an Acer, they're complete garbage and account for about 50% of the work I get.
Mine is an Aspire 5672 and had the same prob. with the cursor locked at the welcome - every boot - and all FN keys were not responsive.
Boot into safe mode's fine, though!
Clean install a few times - so virus is unlikely (flushed BIOS too).
Swapped the keyboard-plate, no joy!
After I uninstalled the original mouse driver, cold boot was ok.

I did notice that the laptop was unusually "hot", especially the battery, so I unlogged it.
That was last month. It is now working as a home station without a battery but plugged-in, operating at normal warmth.
Hope this could help others with similar situation.
The easiest way to get around this is to press F8 (to bring up the safe mode option menu) and selecting the "last good configuration" option. Log on as normal, this should avoid the keyboard and mouse lock issues.
Negative I have restored my computer several times and mouse and keyboard work in safe mode only but as soon as I boot normally I no longer have mouse, keyboard or touchpad availability. Has anyone been able to figure out how to fix this yet???
Doing a system restore solved my problem.

My issue was my keyboard was the only thing locking up at the startup screen, my mouse was fine. Also would work on the BIOS but not on startup.
how did you fix this?
hey guys I had the same problem wirth a windows vista I dont know what caused it but from googling around I heard it might have been a windows update but anways I got I working again woo of my friends had a computer they didnt use I took out the hard drive and it fit rite it works so I know it wasnt the usb port or the keyboard fried
I want reformat my system,but my keyboard cannot working restarted time.And not possible open bios.How to salve this problem.
acer 5600 same problem same symptoms, remove battery, proplem solved. wasted much time anti virus f keys system restores complete vista reinstall doh
Hi I had the same Problem with my acer aspire 5670.
The unit has a new Mainboard and new hard drive as well as fresh Xp install
But the on board keyboard and onboard mouse did not work. Remove the battery and works great runs cooler also.