My Passport not detecting

Closed
Dolphy - Sep 7, 2010 at 05:45 AM
 PWang - Oct 25, 2010 at 03:01 AM
I have a 500gb WD My Passport..On connectin it to my lappy windows recognises the external drive however it does not show anywhere in my computer so i cannot actually access it..I also tried using another another usb cord and also tried it on other lappies but it doesn't work..please help!!!!

3 replies

closeup22 Posts 8924 Registration date Friday May 15, 2009 Status Member Last seen October 7, 2010 2,108
Sep 7, 2010 at 11:09 AM
Hi there,

Have you tried in disk management?if not then open cmd and type diskmgmt.msc press on ok then give your feedback for further instructions,

Thanks
0
I've tried the disk management option as well..however in that the initialization of the disk never happens it always gives out a remark as 'Incorrect function' and therefore none of the properties of the hard disc can be seen in the virtual disc manager
0
I had the same problem on My Passport Essential 320Gb for a while. In addition, sometimes the drive showed up but disappeared after several folders were opened. Often the clicking sound was also heard from the device. The problem is because the power supplied from the computer is not sufficient to drive the WD device. See the link below:
https://support-en.wd.com/!&p_li=&p_topview=1

The problem can be solved by using a power booster cable as sold on WD on line store. But now it is out of stock. My problem was solved by using a similar cable found in a local computer shop, only A$5. It has two USB heads going into two USB ports on the computer and one head going into the WD device. By this arrangement, the device can draw twice the current as the one a single USB cable could supply. So the device has the enough power to work.

I hope this will give you some help.
0