Why won't my wireless connection work???

annie1987 - Oct 5, 2010 at 02:50 PM
jack4rall Posts 6428 Registration date Sunday June 6, 2010 Status Moderator Last seen July 16, 2020 - Oct 5, 2010 at 04:22 PM
I'm using XP Service Pack 2 on my PC at the moment, I put that on my PC way back in May and my wireless connection Belkin G Plus Mimo Adapter was working fine until Saturday after 5pm I had a trojan a fake program getting me to buy anti virus software, I did a system restore and all of a sudden my internet doesn't work which I find very weird, I have tried everything to get it working all I get is no wireless networks in range make sure wireless switch is on, well I've turned the router on and off and it hasn't done anything at all, I've uninstalled an reinstalled the Belkin Adapter and it still doesn't work, I have tried refreshing the network list and nothing shows up. I went on command prompt it says media disconnected, so don't know what the hell is wrong with it because I have a popup on my system tray that says one or more wireless networks detected but when i click on the message it shows, nothing is shown on the wireless network list. I have tried everything and I am losing my patience because I am running out of ideas on what to do, if I wiped my harddrive clean would my wireless connection work?? The only thing Id have to do is put Service Pack 2 back on again but that's not a problem and it's not a problem putting all my programs back on either. I just need some advice here please help!!

3 responses

I am using my brother's PC rite now coz he has got an internet connection which is weird, the router is downstairs and I never had a problem before. When I go to repair the connection it says cannot finish repairing connecting to the wireless network, another weird thing is that my Belkin adapter flashes green and when I've gone on network diagnostics it said something about a problem with ethernet and my wireless connection a communication problem??...That's odd because it worked at 3pm on Saturday but than didn't after i did that system restore, well it was the only way to get rid of that damn trojan.
Also on the popup next to wireless on the system tray, it has got a red cross saying not connected, I have gone on network connections as well and it has said not connected.
jack4rall Posts 6428 Registration date Sunday June 6, 2010 Status Moderator Last seen July 16, 2020
Oct 5, 2010 at 04:22 PM

Try this 1.

Click on Start --> Run --> Type devmgmt.msc and click on OK.

"Device Manager" window will be opened.

Expand "Network Adapters" or click on "+" near it.

If you notice any red cross mark, then right click on it and select "Enable".

Also check your SSID and the security key.

Good Luck.