WD Elements not being recognised properly [Closed]

Report
-
 Ziza -
Hello,

Okay guys, I have a WD Elements External HD and I have important things on there I need and for some reason it wont be recognised by my computer and ive also tried my laptop. I had previously just gone to europe on a holiday and I had taken my external there and then 1 night it decided not to work. Ive been looking around and some say that the USB cable is the problem.

Okay so what happens? Well when I plug my external in, it comes up listed in My Computer but then its name is just Local Disk...normally it would have a WD logo and the name of the external HD but that doesn't happen. If anyone has experienced this problem before please let me know what the problem is...Much Appreciated!

Thanks.


5 replies

Posts
1023
Registration date
Saturday May 23, 2009
Status
Contributor
Last seen
October 20, 2010
243
try doing a check disk on the drive.

Hi,

Have you tried with another usb data cable?Try this:

https://ccm.net/faq/2372-external-usb-hard-drive-not-recognized-in-windows

Thanks
Well to give you guys a bit more of an explanation... Basically when I plug my external hd in it recognises it and then a box will come up with autoplay which comes up all the time and is normal and then it will ask me if I want to open my HD but the auto play box comes up and then when I go into my computer normally the external will be listed along with my other HD's and it will have a WD logo on it and the name of the HD but now it doesnt have that and it just says local disk. When I go to open my HD My Computer freezes for about 30 seconds and then a box will come up saying for me to reformat it... I dont particularly want to reformat as I do have all my things backed up on there. I haven't currently tried another USB cable cause I dont have one the same as mine so which means im going to go have to buy one and see if that works. I also checked the disc and its saying that its working fine but I cant get into it? And this problem happens on my laptop which is running vista and on my desktop which is running XP
BUMP for this topic. I'm having the same problem without any solution in sight.

HELP PLZ!
Hey guys,

I have the same problem with my WD Elements 1TB disk. I've gone through the internet, searched everywhere. Tried to solve the problem on windows and linux but no solution.

To tell the truth, what happens to your disks (also to mine) it means that your drives are not in good health. They have bad sectors. If you scan your drive with WD tools (Extended Scan) you will see the result as this.

So there is nothing more that you format your disk and make a data recovery. If there are important files on your drive send it to a data recovery service which WD supports (you can find a list of them on WD website). That is an option only if you can afford it cause cheapest recovery cost around 400 €.

So these are the options to recover your data. Afterwards if your drive's warranty is not over sent it to WD and get a new one. If not, just trash the harddrive after all these since the same problem will occur again. Buy a new one but not elements. TryPassport or My Book.

Sorry for the bad news.

Cheers...