My Computer won't recognize external HD

 twinstaiye -

I recently purchased a 1TB Seagate Freeagent and not soon after I transferred several hundred gigs to it the top heavy case fell over, snapping the usb connection off of the board. I removed the SATA HD from the case and installed it into a Rosewell 3.5" HD enclosure with ease.

When I plugged it into my computer the icon on the bottom of my vista toolbar which is the seagate "device manager" flashed that 'no drive is connected.' I didn't get the typical usb with a green check icon where you can safely disable hardware until the unit had been plugged in for about 10 minutes. I thought I was home free, but 'My Computer' doesn't have the drive listed.

The device manager shows the drive as ST310003 40AS USB device. I attempted to update the driver, but it said the necessary driver was already installed.

Any help would be greatly appreciated!

12 replies

Cleaning your registry using any software, and the latest Vista update, somehow removes any drive management settings on usb drives and stops letters being assigned to previously Plug'n'Play drives.

Semi Remedy

Connect the drive but do not Format the drive, right click 'my computer' then 'manage' go to 'storage/disk management' view the drives; your usb drive will not be allocated a drive letter. You can set one manually or leave it for about 2~5 minutes for one to be allocated auto. Each time you connect the drive you may have to do this.

It must be caused by a setting being disabled from an update or change in the registry. If anyone can find what setting has changed please reply so we can all modify this pointless bug.
here is what I did. I am using windows 7. Click start, type disk partitions, dont click enter, on the drop down list click "create and format hard disk partitions" when it open, right click your external hard drive among the list of drives listed, click change drive letter and paths, click any of the drive letters that appeared or better still, click Add, and click any drive letters. click ok and your drive should be visible. Hope this helps
Registration date
Wednesday October 8, 2008
Last seen
June 15, 2019
I would first uninstall the Seagate software. It's looking for the hardware that was in the Freeagent box and not your new hard drive adapter. Many of these NAS boxes do not use standard recording methods and the drives are not readable outside the original box.

If you don't need the data that is currently recorded you can use Vista to partition and reformat the drive and it should be usable in the new enclosure. Get back to us if you need help with formatting.
I have the 1tb turbo usb external hd too. I have the same problem as MEITTI except I tried it on my xp and and vista both same problem....when it eventually shows up on my computer it says 'local disk' instead of the usual name and icon. When I double-click, it tells me it needs to be reformatted and when I try to right-click, it takes forever before it shows. It doesn't let me disk check it and doesn't let me explore.

Now I know everything is still fine on the harddrive because when I connect it up to my Xbox 360 it accesses everything perfectly fine. All the video's and music etc works as always. So now I really want a solution without having to revert to reformatting. I have almost 600gb of data on there. I can't afford the same time and effort it took to collect all of that data again.

Oh yeah I tried putting it in the freezer (obviously wrapped in loads of plastic bags). It did nothing (although it worked with something else before)

So any help would be great! Thanks!
but what if you do NOT want to reformat. I have the same issue. vista ultimate is installed and it sees the USB mass storage in device manager. I didn't load any drivers. I have a NExstar CX 2.5 with a hitachi HD. I tried it on my XP machine and all is well. something is up with vista.

any ideas?
ok, this is weird. I jacked my external HD into an XP pro and it recognized it fine. then I jacked it into my vista and it recognized it. prior to jacking it into my XP it wasn't recognized in vista.

strange but hey it works now.
Interestingly enough I had the same exact issue with a new NexStar3 eSATA enclosure and a Western Digital 500GB hard drive from a previous enclosure that went bad.

After putting the drive in the NexStar3 enclosure I could see all the data when plugged into an XP computer, but when I plugged the drive into a Vista Business computer it would only acknowledge the disk in DISK MANAGEMENT. The drive itself wasn't browsable.

I ended up reinitializng the drive on Vista and then I could use it, but when I went to XP it would only find the drive in DISK MANAGEMENT.

I then deleted the partitions and re-created with XP. Copied my data back to the drive. Plugged and unplugged into a 2nd XP machine just to verify I could see the drive with multiple computers. I could.

Low and behold I then take the drive back to VISTA and now all of the sudden the drive is visible to explore.

Maybe this has something to do with the logic of the controller in a NexSTAR enclosure?
Hi Guys,

I'd just like to let you know my fix for this problem. I have a WD My Book 1TB external HDD. I had just upgraded my PC as well as intstalling XP again. The HDD was working fine as I updated windows though it failed to be recognised. I had tried everything, unintalling and reinstalling drivers, updating mainboard software, USB software, HDD firmware on another PC, deleting registry values. Nothing.
The final solution was systematically removing windows updates. And as about the culprit in .NET frame work 3.5 service pack. Bloody Windows!!! Hope this helps other with this frustrating situation.
It's definitely Vista upgrades which have something against it. I have Buffalo's HD-CEU2 Drivestation TurboUSB, which worked just fine yesterday, until I patched my Vista. And now it says that I have to format that hard disk, before I can access, fix, or even rename it. I really DONT want to do that, for theres some vital data inside, which's recovering is a hard task in itself. And the external drive was solely meant as a storage device for me anyway. So if I format it now, lose all the data, painfully get all the data back there, theres always the possibility it may do that AGAIN, which kind of kills off the idea of using the hard drive in the first place, if you constantly have to keep formatting it.

I havent tried it on my friend's older XP-computer though, but the problem is definitely with Vista's updates. Some sort of a constant solution for this problem would be nice. Other than clearing out all the data.
This is happening to me too since I installed IE8 Compatibiliity view list update and the .NET 3.5 SP1.

Possibly also defender definition

This is happening on my Seagate 1.5 TB, but not on my Western Digital 500MB.
Cant really find solution on internet about my problem.

I have 2 external USB2.0 Harddrives (PackardBell 400GB, WD 1TB). Each one has 4 partitions (ex. E,F,G,H). Since instalation of SP1 on Vista on my laptop HP DV6000 some partitions just simply doesn't show up in the system anymore..just every 2nd partition is visible...(E-OFF,F-ON,G-OFF,H-ON). On each drive is the same thing.
Every time ONLY 1 USB HDD is plugged there is no issues with too many drive letters or some drive letter crossing etc.

The MAIN thing is...that ALL External partitions are visible as usuall on WIN XP system on my PC right now. These partitions also WERE visible on my Laptops Vista BEFORE installation of SP1.

If anyone can tell me which update exactly (within SP1 for Vista Home Premium ENG) is causing this problem I will be grateful!
I have had this problem.

Surprisingly, the answer is fairly simple.

Symptoms: Hard drive (a WD MyBook 500GB, and WD MyBook 1 TB, in my case) is not recognized by the computer (Windows XP Windows Explorer program). Happens intermittently, especially after my "cleaning ladies" have visited. Problem is not solved by power cycling the computer, or just rebooting the computer. Problem was solved by disconnecting the power for a few minutes from both the computer AND the disks, then restarting the whole system after restoring power.

Cables to the disk (in my case, going to an external USB 2.0 hub) were checked and found to be OK.

These WD drives have a--hard to see-- button on the back that resets their "state". Press it for a while till the disk clearly is "going into a reset or power down state"; then press it for a second or so so the disk repowers itself.

The disks have somehow become confused (I surmise because the inrush current of the cleaners vacuum cleaner has disturbed the state machine in the disks). Rebooting the computer does nothing to fix the disk problem, since it is the disk controller that is confused. The disk controller will eventually reset itself if the power is left off for a while(i.e., the disk is unplugged), but this is inconvenient. WD's documentation doesn't mention what the button on the back of the disks is for, but its most useful function is to power cycle the disks, and RESET THE INTERNAL STATE MACHINE.
Windows VISTA fails to recognized Hewlett-Packard USB hard-drive unit - and VISTA freezes and locks when the USB is inserted. No problems with WindowsXP or earlier versions of Windows - - - therefore VISTA seems unable to operate USB removable media - and not yet sure if SanDisk or other memory chips will work