Laptop is not powering on. [Closed]

Report
-
 Aly Tehhero Thedgerow -
Hello,

Hoping someone can help:

My ASUS A6403KM notebook does not power up. When I turn the power on the lights come on for quick second and then automatically shuts down. Ive tried taking the battery out and then turning on same thing happens. Ive also tried taking battery out and mains and pressing power button 3 times (as per ASUS support center advice) and replugging in mains power and still same problem. ASUS service centre suggested montherboard needs complete removal (he is 99% sure did not open the laptop or anything! - very pricy this option). Im hoping someone can offer some alternative advice on what they believe the cause is or how I can reticify the problem.

Thanks

Avinash.k

1 reply


Um... have you tried plugging it in and charging it? Sometimes (at least for my laptop), if I leave it near a hot heat source, it drains the battery and needs to be charged. Just plug it in and let it sit for a few hours, then turn it on.

it's okay. *pats on back*

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!