NFS : Hot pursuit (2010) - Black Screen [Closed]

Report
-
 Nex -
Hello,

I have installed the subjected game on my windows 7 installed laptop and when I started the game everything works well except when the race starts the environment is black. But the car, route map, etc are visible perfectly and the car is running smoothly. I have tried to update my display driver and my pc meets all the system requirement. My graphics device is intel chipset 4 series.

Any help will be highly appreciated

Thanks in advance

Related:

2 replies

Posts
4521
Registration date
Thursday August 19, 2010
Status
Moderator
Last seen
August 3, 2016
951
Hello,

Is your game a purchased or downloaded game?
i got it from my friend who installed & played it successfully. It a cracked version.
But one doubti have is about the size of the installatoin DVD. It only 4.17 GB where as waht I found in net is around 7GB. anyway I could install it without any problem. Only problem with the black objects when rae stars.
I have downloaded the latest drivers from Intel's site http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Graphics&ProductLine=Desktop+graphics+controllers&ProductProduct=Intel%C2%AE+HD+Graphics&ProdId=3231&LineId=1100&FamilyId=39
and the problems were gone! Now the game runs on max settings (though a little bit slow)!

So, my advice to you:

1) Download the latest drivers for your integrated Intel video card (the drivers on Intel site are as of October 23, 2010)
2) Turn off "blur effect" in NFS graphic options
3) Set other graphic settings by "trial and error" to get the game running fast
4) Enjoy it :)

Tell me if it works