Acer Aspire one ZG5 cant flash bios [Solved/Closed]

 Dawgs -
on this netbook is black screen, I am tryin to flash bios on ZG5 with SSD by this manual:

1. Go here and download and extract the latest BIOS for the netbook.
2. Rename the BIOS file from 3310.fd to zg5ia32.fd.
3. Copy zg5ia32.fd and Flashit.exe to USB flash drive
4. Ensure that the AC adapter is plugged in.
5. Insert the USB flash drive into a USB port.
6. Press and Hold down the Fn and the Esc keys together and press the power button.
7. When the unit's power light comes on wait a few seconds and release the Fn and Esc keys.
8. After the keys have been released the power light will start to blink.
9. During the BIOS update process the display will be blank.
10. Let the unit run and after approximately 1 to 7 minutes, the unit should reboot and the BIOS will be updated.

but nothing happens, just power LED is blinking. Im tried 2 USB sticks formatted FAT. I use bios for acer aspire one 110 from , and also for 150, but no success. Can somebody help me?
Thank you, Mark

7 replies

Ok thank you,
i have ordered new programmed bios chip, I hope that new chip can solve this problem
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month

Registration date
Wednesday October 8, 2008
Last seen
June 15, 2019
Using the wrong BIOS can permanently disable the laptop/BIOS chip. Then the only recourse is to physically replace the BIOS chip with a correctly programmed chip.

Good Luck
hello, I have exactly the same problem with the same netbook. Did you solve the it with a new chip ?
i am just waiting to new chip, when I received the new chip I will write there
Thanks ........ !
Problem solved by using the process ...
Ashutosh Dutt, Saharanpur U.P. , India
i have soldered new bios chip, but the same problem.
new chip not solve the problem. I dont know what is with it.
I got mine fixe after opening it and removing the backup battery for a while. But I also formatted my flashdrive in different linux which had maybe a better program for it. (Fedora 17 disks formatted as WIN95 FAT32 instead of only choosing fat16 or fat32 in ubuntu)
I had similar issues. I fixed it after several failed attempts.
I followed this guide:

Hold down keys fn+esc and power up the laptop, when the power led begins to blink release the two buttons and press the power button just once, observe the usb stick flashing indicating it's flashing the bios, please note this can take a few attempts, I once struggled for a few hours until I finally tamed the beast :)
be patient okay

--> From this statement I saw that it can be tricky to get the new BIOS to load. One more try, this time pressing the power button just once AFTER I released the fn+esc keys, and voila!

good luck!

I have the same problem after using the KAV80patched.fd my acer aspire one zg5 just shuts down and never starts again.

I've tried using the flashing process stated above but the power button does not blink or no green color it just like it is already totally destroyed..

Please Help..

Thank you.,,
you must unsolder bios chip and program correct bios in programmer, or buy new programmed bios chip
..I guess that's the only option I have .. :)

Thanks a lot elemaro :)..

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!