Acer aspire one ZG5 Recovery [Solved/Closed]

-
Helloe, my friend got the new Aspire One ZG5 based. But now thanks to a virus, the MCAfee that's used isn't helping at all, it just detects and deletes the infected and(or) system files !

There are two partitions: one is 149 GB (single active drive, i.e. C) and the other 8GB is for the system drive. At first we wanted to see if we could hook up an external optical drive to start installing Windows over again, but I remembered that if 8GB is kept aside, it must be used to sort of repair Windows or at least install it over again, right?

What do you advice we should do? And is it possible to hook up an external DVD writer to the lap top? Any suggestion on your part, will be of great help to us.

Thanks, waiting for your reply.
See more 

20 replies

Best answer
Posts
19490
Registration date
Wednesday October 8, 2008
Status
Contributor
Last seen
December 4, 2018
283
Thank you
Using Acer eRecovery Management, if you still have the original HDD, you can go back factory settings.

You can launch Acer eRecovery Management in a number of ways:
  • By pressing the hotkey <Alt> + <F10> during the boot-up process, or at any time when you are running Microsoft Windows.
  • From the Start menu, go to Start > (All) Programs > Empowering Technology > Acer eRecovery Management.

Thank you, xpcman 283

A few words of thanks would be greatly appreciated. Add comment

CCM has helped 2370 users this month

Thanks it saved my brothers computer
you the best
cheers for this, had been a headache for the past wee
thanks it is going recovered and repaired ...from UK Nicu777
46
Thank you
I just order the restore CD from Acer. As soon as I get it I will compress it as an .ISO and post it for all who needs it. Acer Support is the most USELESS source of help on the market right now. My Aspire One is only 95 days old and they told me then can't support me cause my 90 day waranty is up. Can you believe that? They have three dollar amount for support. $36 for the first thirty mins. $90 for one week, and $129 for a years worth of support. The Acer Aspire one on sale right now for $169 at Compusa and Acer wants me to pay that. NEVER!!!! Bunch of crooks! I broke down and just bought the restore CD now can someone help me to install it. Because Acer Aspire One does not have a CD rom to install the restore software!! The Support tech told me to call back and pay someone to walk me through the process, NEVER!!!! I totally recommend DELL Net book. Support staff much more helpful!!!!
Hey man, did you ever get that recovery cd? if so is there any way you could send me a copy of the ISO? I am going to be upgrading to windows 7, but the way microsoft handles upgrades, I have to already have xp installed on the system to upgrade. Unfortunately I deleted xp from my system to install the windows 7 beta, and now they want me to pay for XP again, just to then upgrade to windows 7... Acer is such a scam..
> popestt -
are you delete EISA Partition on your netbook? if not, you can get the original xp. if you delete your xp and install win 7 and your win 7 corrupt, you still can get your original win xp by pressing <alt>+<F10>...
Could I get a copy of that iso? My Acer ZG5 has the SSD, so no recovery partition. :(
My friends aspire one zg5 just took a dive. I would like to know if I could get a copy of those disks so I try to restore it. I have tried all the key combo & nothing works.
Thanks.
30
Thank you
Hey I know what to do in order to restore it but when I press restore system to default thing..
it restarts my computer and then just loads windows up normally any one got a solution?
and if I press alt+F10 at startup nothing happens...
26
Thank you
Thanks to whoever posted this solution. I was able to boot from my XP cd, without buying the Acer recovery disks and now i'm fine.

<<You must switch the SATA Mode (BIOS) to IDE from AHCI.

Hit F2 at boot screen -> Main -> SATA Mode -> IDE

This will allow Window XP to see your SATA.>>
22
Thank you
switch on the net book and press ctrl f11 the netbook gets restored to its factory settings in 15 mins.
14
Thank you
i've a aspire one D150-1BW
alt + f10 didnt work
i've had to touch ctrl + alt gr + f10
thanks for the hint i'had never figured it out all by myself
10
Thank you
most external dvd writers are gonna fail for you if you have something messing with you to badly (massive registry errors, system32 file gettin swaaped with corrupt garbage.) acer's e-recovery "ghost drive" is set up to boot with the command ALT+f10. so while the computer is booting up, hit alt+f10. then from the recovery window, you can either completely wipe everything and start with a fresh xp, or just try to repair. if u try to just repair, then any documents and settings and such that the user had will be saved under C: Backup. or C: Backup 1 or so on depending on if you have done multiple repairs. :) good luck!
6
Thank you
After you enter the BIOS by pressing F2 during boot up scroll over to the BOOT menu and press enter . Scroll down to the last option USB CD Rom and then use the F5 key to move it to the top of the boot list order. Then press escape and then F10 and enter. Then use your DVD /cd burner to load XP.
The F2 on boot up get's you to th BIOS and Select USB CD/DVD for first boot. Mine hasn't died yet, but I have the restore DVD's, and was able to boot Fedora Core Live on the Aspire One XP Web Book.
Works fine here..
3
Thank you
thanks so much for the info I have been trying to find a way to restore my daughters computer for a week now and found this. she will be so happy when she gets home from school.
3
Thank you
Thank You Sooooo much for providing the information about switching to IDE mode!! After that, the brand new SSD disk were found on my brand new Acer Aspire i5 notebook!!
Before that, I thought I've had destroyed the whole maskinos....:-)
2
Thank you
Thank you sooo much thanks alot it really saved my life thnks............
0
Thank you
For those of you that have Aspire One (netbook) and window XP installer could not find HD problem.

You must switch the SATA Mode (BIOS) to IDE from AHCI.

Hit F2 at boot screen -> Main -> SATA Mode -> IDE

This will allow Window XP to see your SATA.
Same problem here but didn't notice your post until I had recovered teh drive using Linux Mint 8.
Heres's what I did:
- connected my USB DVDRW
- set teh USB CD option as boot device (F2, boot )
- insert Linux Mint and booted up the netbook
- selected GPARTED from teh applicaitons and then....
- set the PQSERVICE partition as boot and set the other partition not to boot;
- close GPARTED & QUIT Linux Mint.......
- Disconnect the USB CD drive and Acer One boots into XP Recovery sequence
- Selected the safe recovery option to place all users file in the C:/backup folder.
- Continue Win XP install as per usual process.
Also, I have removed Macafee and other free software as it is mainly crapware and have installed AVG9.0 and Spybot to protect the netbook.
All now working OK.
If it were MY NETBOOK then I would upgrade it to 2Gb RAM and install a dual boot Win7 / Linux option, however I am using an IBM Thinkpad x60s which is MUCH MORE USEFUL than the Acer for general day to day work.

Best regards - Pete
I can't find the SATA Mode on the BIOS????? I press F2 > Main> and I only have Quick Boot, Network Boot E12 Boot Menu and D2D Recovery but nothing SATA Mode......Help please!!!!
Acer AspireOne Netbook Computer has Windows XP and Anroid OS (bought it Dec 2009). The cursor is erratic and doesn't function. First, just in Windows, then also in Android. I tried Alt = F10 and it seemed better but then back to erratic cursor and dysfunctional. Then it would not do the reboot thing on next try with Alt + F10.

So, I tried ALT + F2 > Main > SATA > Change to IDE

After that, when I power up the computer it goes through the Acer logo and then the screen goes black.

I tried ALT + F2 again but the arrow keys do nothing so I can't change IDE back to AHCI again.

Then I tried ALT + F10 and the screen goes black. I tried ALT Gr + F10 as I saw that suggested but the screen is black. Guess I erased everything somehow?

Any suggestions? Guess there's always putting it back in its box and sending it off but I hate give up. I am 5000 miles from home and would like to make this work if possible.

Thanks,
DLong
Hey DLong, it sounds like a corrupted bios. You might be able to reflash it from a USB stick. Otherwise it involves taking the top off the machine to reset it to factory default, which isn't difficult but will probably void your warrenty. There are tuts on both on these things around. Google "aspire one flash bios" and "aspire one black screen" I guess.
I did what u said... I change SATA to IDE, and D2D recovery is enabled. I have tried pressing alt f10 and also from the eRecovery Management but nothing works... Anything else I can try? I'll wait for your answer, THANKS!!!
0
Thank you
Switch ON & pressing the hotkey <Alt> + <F10> during the boot-up process till eRecovery up on screen
0
Thank you
Before starting to windows press alt+f10 or ctrl+ f10, try using both of them and windows recovery will start.
0
Thank you
Thanks for the tip. Alt-F10 was the way to recover it.
0
Thank you
AMAZING!!!!!!!!!!!! I can not thank you enough for all the help. Now I don't have to kick this piece of shit down the stairs! Lol. Alt+F10 Gets a 5star rating from me! :3
Posts
1
Registration date
Tuesday March 2, 2010
Last seen
March 2, 2010
0
Thank you
I think that you may need to perform the bios upgrade on your Acer before you can get it to boot up again. The solution is in this thread, and I copied it as such :
-----------------------------------------------------------------------------------------------------------------------
I ended up contacting Acer. They gave me the right Bios and instructions to flash it. It's working now.
Go here:

http://www.acer.com.au/...

Go through the menus, and select the AOA150, then select the BIOS tab. Download the one you need (I used 3309, that was the one attached to the support response) Follow instructions below.

Requirments
256MB USB drive or higher capacity.

1. Insert your USB drive/thumb drive into a working windows system. Open up my computer or computer and locate your usb drive and right click and select format. Format the drive with ‘FAT’ file system and not FAT32 minimum 256 MB in capacity.
2. Download the attached zip file AS1_BIOS_3309.ZIP
3. Extract the files on the root directory of the USB Flash Drive.
4. Turn off the Aspire One and make sure that both power adapter and battery are connected to the netbook.
5. Plug in the USB stick to any port on the failed Aspire One
6. Press and hold Fn+ESC and then press the power button. The power LED will now be blinking.
7. Press the power button ONCE. During this time, it will now initiate the BIOS update, DO NOT INTERRUPT IT UNDER ANY CIRCUMSTANCES.
8. After about 2 minutes, the power LED will stop blinking and the Aspire One will reboot. The BIOS is now complete.
9. IF the unit DID NOT REBOOT BY ITSELF, wait a further 5 – 7 minutes before rebooting the unit as the BIOS may still be flashing.


Best of luck. All I know is it worked on mine.
-----------------------------------------------------------------------------------------------------------------------
AND ALSO THESE INSTRUCTIONS FOR THE ZG5:
-----------------------------------------------------------------------------------------------------------------------
It worked for me. I only had to rename 3309.fd to zg5ia32.fd.

People who still have this problem,(Acer Aspire One ZG5 won't boot up, working with black screen) this is what I did:

------------------------------------------------------------ ------
Download & Extract AS1_BIOS_3309.zip (from : http://support.acer.com/...
Rename the Bios name from 3309.fd to zg5ia32.fd.
Copy zg5ia32.fd and Flashit.exe to USB flash drive.
Start the restoration process:

A. Plug the AC Adapter into the unit.
B. Insert the USB flash drive into a USB port.
C. Press and Hold down the Fn and the Esc keys together.
D. Keep these keys held down and press power.
E. When the unit's power light comes on release the Fn and Esc keys.
F. After the keys have been released the power light will start to blink.
G. Let the unit run and after approximately 1-7 minutes, the unit should reboot.
H. Video should now be restored
------------------------------------------------------------------------
these information is taken from this aser website:
http://support.acer.com/...
==========================================
i copied all three files: 3309.BAT, zg5ia32.fd , FLASHIT.EXE to root of my USB
you must also format your USB with fat file system (not fat32) with "Allocation unit size" set to "Default allocation size" before coping those three files
------------------------------------------------------------------------------------------------------------------------
I know that this may look complex but follow the steps methodically & you should be up & running.
0
Thank you
guys, can try to hit ALT-F10 when booting. Cheers!
0
Thank you
I bought an Acer Aspire One 532h-2Cb (XP) about 2 months ago. I immediately created an image of the system partition with Macrium Reflect and saved this to a DVD and a spare partition on the Acer. Since then I have used this to successfully restore the system twice, including on one occasion when I managed to mess up the Intel VGA driver. Macrium Reflect supports booting from a USB stick using UNetbootin.

I do not know whether this would work under all circumstances but it seems like a good alternative to the eRecovery disk.
Note that if you use this method you must backup all user data, settings, IE/Firefox bookmarks etc. on the system partition and move your My Documents folder to a non system partition. Caveat Emtor!

I also use this procedure on a Compaq Presario laptop and my desktop system and have had no problems over the past 2 years.

Hope this helps.
0
Thank you
Your the best mark :-) thanks from greece