Toshiba sat c655-s0582 won't load the BIOS

piratadave - Feb 20, 2012 at 08:33 PM
 Blocked Profile - Feb 20, 2012 at 11:57 PM

I have a Toshiba Satellite c655-s0582.

My sister dropped it down 3 months ago and just shooted down. Turned it on again and everything was working perfect.

5 days ago I was working on it and shoot it down as normal. Next day I tried to turn it on but nothing happens, theres nothing on the screen, the BIOS won't load, all I hear is the cooler fan and the it shoot downs it self, and from the time I press the power button to the time it shoots down theres only 6 secods.

Tried to turn it on without the battery and plugged in thinking on a battery problem, but stills not work.

Tried to plugged it into a monitor thinking on a LCD problem, but theres nothing on the monitor.

Tried changing the RAM to a different DIM, but stills not working

And finnally changed the BIOS battery, but stills not working.

Any idea?

1 response

Blocked Profile
Feb 20, 2012 at 11:57 PM

Please, bare in mind that Kioskea is a mutual aid community, all answers on the forum are provided by volunteers who give their time free to help solve issues.

Therefore, it is specifically requested from Kioskea forum users correspond showing mutual respect. Therefore, when requesting assistance, the use of polite expressions,as for elsewhere in similar circumstances, is appreciated. (please, thank you, appreciate, grateful, etc.)

Please, copy, modify and repost your message respecting the politeness charter.

We trust that you understand.