Toshiba laptop satellite c660 not booting up [Solved/Closed]

Lind1we 1 Posts Monday October 29, 2012Registration date October 29, 2012 Last seen - Oct 29, 2012 at 03:06 AM - Latest reply:  lijoy
- Sep 22, 2017 at 12:01 PM
Hello,

My laptop isn't working. Ive tried to restore it to an earlier point in ime but that isn't working. Tried pressing 0 and nothinghappens, there is no beep and the page remains on the intro screen. I dont have a Cd or DVD. Im happy to erase everything on the laptop. Please please help

See more 

6 replies

Best answer
Ambucias 53282 Posts Monday February 1, 2010Registration dateModeratorStatus July 20, 2018 Last seen - Oct 29, 2012 at 04:21 AM
4
Thank you
Try this 1

1) Unplug the power cord --> Remove the battery --> Hold the power button for

60 seconds --> Connect the power supply then try to switch ON the laptop and

later put the battery back into the laptop.

2) If the problem still exists then click on the below link and follow the instructions

http://ccm.net/faq/9066-display-problem-laptop

Good Luck

Thank you, Ambucias 4

Something to say? Add comment

CCM has helped 1680 users this month

Could not get the laptop to boot. This fixed the problem.
Thankyou so much. This solution worked perfectly.
Thanx mannnn
Thanks, it really helped
bramossjyjy 12 Posts Wednesday April 9, 2014Registration date January 27, 2015 Last seen - Apr 13, 2014 at 02:39 PM
1
Thank you
hi lindiwe

did you create a ''restore point'' before , is very important to create a restore point and backup all the time.