ASUS laptop internal speaker is not working. [Solved/Closed]

Posts
3
Registration date
Tuesday December 11, 2012
Last seen
December 18, 2012
- - Latest reply:  aron - Jan 19, 2015 at 01:21 PM
Hello,
my ASUS laptop speaker is two weeks old. the sound didn't work after I put my laptop in 'sleep' mode. even by using the headphone the sound also didn't work. I'm using Windows 8. please help me.. :(


See more 

10 replies

Best answer
approved by Jean-François Pillou on Nov 26, 2018
Posts
2403
Registration date
Sunday September 23, 2012
Last seen
December 13, 2018
650
7
Thank you
Hi GEMHOLOGRAM,

This could the problem with the sound settings or the driver's issue.
  • Try to uninstall the audio driver and then install it again. If you need help with finding the correct drivers, please provide me the Device Instance ID of the sound card. To get the Device instance ID of the Sound card, right click the My Computer icon on the Desktop, select Manage, select Device Manager under Computer Management from the left pane, then expand Sound, video and game controllers from right pane.
  • Right click the Device listed under Sound, video and game controllers, click properties, go to the Details tab, and then select Device Instance ID from the drop down list.
  • Make a note of this Device Instance ID.

If this doesn't fix the issue, try running the diagnostic tests provided by the manufacturer on the sound card.

Do reply with results.

Thanks & Regards
Zohaib R
#iworkfordell

Say "Thank you" 7

A few words of thanks would be greatly appreciated. Add comment

CCM 4456 users have said thank you to us this month

YAY! This took me a couple days of confusion but I'm glad I found this! Thank you so much
lialala
Posts
2
Registration date
Sunday January 4, 2015
Last seen
January 4, 2015
-
Dear Zohaib R, My asus is going crazy, the speaker doesn't come out any sound. I delete something in the device manger under sound,....(dont remember the rest). and suddenly the speaker is disable and the sound section on device manager turn into other divices. I think I deleted audio driver. I already download realteak 64 bitz but it doesn't effect anything please I need some help, My asus is a notebook and to be worst it's my mom'su asus, T.T
> lialala
Posts
2
Registration date
Sunday January 4, 2015
Last seen
January 4, 2015
-
Go to Control Panel and select Sound. Right click and select "Show disabled devices". Your speakers should show and you can right click and select "enable".
lialala
Posts
2
Registration date
Sunday January 4, 2015
Last seen
January 4, 2015
-
my device instance path is ACPI\10EC5640\1
thanks, I had the same problem and it worked when I right clicked on the sound device and activated it
Posts
3
Registration date
Tuesday December 11, 2012
Last seen
December 18, 2012
5
Thank you
HI Zohaib R,
i already done as you told..at first the speaker work! but when I plug in my headphone and then unplug it, my speaker icon remain as headphone icon and again the speaker doesn't work. is my headphone jack broken or there is something wrong with my sound device?
there is no need to uninstall everything. just open Realtek HD Audio Manager and click on that black round circle under ANALOG, and check speaker.
Posts
2403
Registration date
Sunday September 23, 2012
Last seen
December 13, 2018
650
4
Thank you
Hi GEMHOLOGRAM,

Thank you for reporting the problem. There are some settings in some of the sound card applications than can cause this to happen. Also it could be a faulty audio jack. Request you to please reply with the exact system Model Number of your Asus Laptop, so that I can check the settings in any associated application. Further, as requested in my first reply do add the Device Instance Id of the audio card.

Please do write back to us.
me to, I just got it and im freaking out
my x550c the same problem!!!
Hi all and thanks for the helpfull info, I have an asus and experiencing the same problem. I found the uinstall button and all but then how can I get back to reinstall ?
yeah uninstalling is fine but re-install ? (asus having problem too)
I Have the sane issue!! Please help!!! I tried to unsinstall it ann still same issue!! my headphones dont work!!!
Posts
2403
Registration date
Sunday September 23, 2012
Last seen
December 13, 2018
650
3
Thank you
Hi GEMHOLOGRAM,

I will assist you with the solution. Yes, you are correct uninstalling the audio card and then restarting the computer at times fixes the problem. You are following the right steps, just right click the device listed under "Sound, video and game controllers", select Uninstall and the restart the computer.

Do reply with results.
After I uninstalling,how to reinstalling the audio drivers? Help me~thank you very much!
Posts
2403
Registration date
Sunday September 23, 2012
Last seen
December 13, 2018
650
2
Thank you
Hi PMC,

You can download the drivers for "HDAUDIO\FUNC_01&VEN_10EC&DEV_0269&SUBSYS_10431AD3" from the below mentioned hyperlink:

HDAUDIO\FUNC_01&VEN_10EC&DEV_0269&SUBSYS_10431AD3 Driver Download

Note: This 3rd party link is exclusively my suggestions based on the personal research and experience. Usage of this link is purely based on your discretion.
zazaviolet
Posts
1
Registration date
Saturday January 4, 2014
Last seen
January 4, 2014
-
hello,
i had the same problems too. i'm using asus laptop, windows 8. my speaker doesn't work after using the headphone. but the sound can be hear if using the headphone. already try to uninstall the sound device but still it doesn't work. so what can I do now ?
which do we download??
Posts
2403
Registration date
Sunday September 23, 2012
Last seen
December 13, 2018
650
1
Thank you
Hi akhil,

Have you tried the steps mentioned in my responses to the user `GEMHOLOGRAM'? If not, please perform the same and reply with results.

The user `GEMHOLOGRAM' reported that the initial problem was no sound after waking the computer from Sleep Mode later on it changed to headphone jack related issue. Which one of these you are facing?

Please add the exact System Model Number of your laptop and the Device Instance ID of the Audio Card in your laptop.
my sound icon say no audio output install can you help me
Its the same problem as mine.. My ASUS model is ASUS 1215B..
Is it possible that the ribbon connecting the main board and from the sound port, usb port, and the power button inside my laptop has an issue causing that problem?
It is still no speaker or headphones detected.. what is the possible problem of my ASUS 1215B??
Posts
2403
Registration date
Sunday September 23, 2012
Last seen
December 13, 2018
650
1
Thank you
Hi PMC,

Have you tried uninstalling and then reinstalling the audio drivers for your computer? If not, please install the drivers. if you have difficulty finding the drivers, please reply with the Device Instance ID of the sound card/chip in the machine. To get the Device Instance ID:

1. Press and hold the Windows Key and then press the R key on the keyboard to launch Run Dialog Box.
2. Type "devmgmt.msc" and hit "Enter".
3. Expand "Sound, video and game controllers" and check what device is listed here. If the sound card is not listed here, expand the "Unknown Devices" and check.
4. Double click the listed Audio Card.
5. Click the "Details" tab.
6. Select Device Instance Path or Device Instance Id (whichever is available for your version of Windows) from the drop down box.
7. Make a note of the Device Instance Path or Device Instance ID and add this in your reply.
Hi, I use asus. I have the same problem with my speakers. it says audio service is not running, and there is cross sign on the speakers. I have found Device Instance path instead of device instance id
(HDAUDIO\FUNC_01&VEN_1002&DEV_AA01&SUBSYS_00AA0100&REV_1002\4&16891873&0&0001) for AMD HIGH definition audio device.

beside this I can provide you Matching device ID (hdaudio\func_01&ven_1002&dev_aa01&subsys_00aa0100&rev_1002)

please help me to download the right driver.

Thank you.
HDAUDIO\FUNC_01&VEN_8086&DEV_2880&SUBSYS_80860101&REV_1000\4&1D23FFAA&0&0101
1
Thank you
Hey I hd the same problem, but when I use a headset with mic, it is all working.
The connection on the T100 is alsso a mic connection.
many times a headset with mic is deliverd with your phone.
There are 3 isolator rings on the jack insteed of 2.
Posts
3
Registration date
Tuesday December 11, 2012
Last seen
December 18, 2012
0
Thank you
HI Zohaib R
thanks for the solution. I'm sorry but I don't know how to uninstall it. it is just right click the Device listed under Sound, video and game controllers then click uninstall? I've read somewhere that the device will re-install when reboot the computer. is it true? pls teach me step by step because this is totally new to me. :( thanks a lot for your cooperation. :)
Posts
2403
Registration date
Sunday September 23, 2012
Last seen
December 13, 2018
650
0
Thank you
Hi PMC,

The Device Instance ID (HDAUDIO\FUNC_01&VEN_10DE&DEV_001C) that you provided is for "NVIDIA High Definition Audio". This is actually the device for HDMI Audio. There should be another device listed under "Sound, video and game controllers" or "Unknown Devices", please reply with the same.
this one??
HDAUDIO\FUNC_01&VEN_10EC&DEV_0269&SUBSYS_10431AD3&REV_1001\4&547A42E&0&0001