Laptop won't boot after bios upgrade

Registration date
Friday February 27, 2009
Last seen
November 27, 2009
 Erfan3600 -
I have an HP Pavilion dv9000 series computer. While performing the HP Health Check, it was recommended that I upgrade the existing bios. After downloading, the computer shutdown but upon reboot, computer would not boot up. Instead, I received one long beep and two short beeps. The computer worked fine before bios upgrade. Is there a way to return to the default bios settings on this computer?

6 replies

I had exactly the same problem last night. HP's 'Health Check' recommended that I flash the BIOS of our new HP Dv7-1175. Had the computer about 3 days, and was receiving some strange errors reporting unrecogized USB devices not recognized and a buggy USB driver. So, OK, Flash the BIOS.

Precisely the same thing occurred. The utility for flashing the BIOS ran, seemed to work, shut down the computer. Then nothing.

I restarted to a backlit screen, no POST or BOOT. Here's how I solved the problem (though I can't tell you why it worked, other than it obviously reset the CMOS).

1) Turned off the computer

2) Removed Battery and disconnected power cord.

3) Waited, pensively, for 5ish minutes (read several places to wait for 20 minutes; I didn't)

4) Plugged the power cord back in (I did NOT reinsert the battery)

5) Holding down the Insert/Scroll button, I held the power button down for 20-30 seconds. Nothing happened until I released the power button. When I released the power button (still holding the Insert/Scroll button depressed), the computer came up and Windows booted. Could not, at that point, get ESC pressed; wouldn't let me into the BIOS.

6) Restarted and prayed, came up normally; opened the BIOS by hitting ESC at the proper time, reset to defaults (just to be sure).

The computer has seemed to work operate normally since, though for the life of me, I can't tell you why this worked. I was, for the record, trying to press the Insert button, so if yours has these separated-- as my Toshiba does-- then I'd start with that.

Hope this helps someone.
Hey Shantyhag,

Thanks for your solution...

It worked for me too ...

I have an HP Pavilion dv5 1080e Notebook. I tried to install Windows 7 Rc 1 yesterday on my laptop. After Windows installed, the laptop rebooted and stopped working.

When I press the power button, I get the black screen with the HP logo but nothing else happens. It just hangs. Seems like my Bios is not booting.

Can anyone help please. I did try the steps which Shantyhag suggested but still teh same problem, I could be doing something wrong or just doing it the wrong way.

Please help.
hey ,

dude this is due the win.img this file have several file which are used after installlation as drivers , application etc
if that file is corrupted then this problem occurs so install fresh copy of win 7
> eddy
Hiii... tried to install windows 7 RC1 on hp pavillion dv4 laptop.... but after the installation asked me to restart the computer stopped working... it wont boot and is stuck at the screen with HP invent LOGO. Any idea how to get this fixed? Thanks
OMG dude I cant tell u enough for the fix I almost went to best buy to get it fixed now my laptop works perfectly Thank You so much PPL like you diserve the best
Registration date
Monday August 4, 2008
Last seen
May 19, 2009
I think you should remove the CMOS battery and plug it again after some minutes then try to reboot your pc
pls. enter in setup using f10 or any other designated key, go to system configuration and disable sata native support. it will surely solve the problem

Email Id removed for security
it worked for me when I chnged the sata to compatibilty mode thanx a lot
HP Pavilion Desktop x64 (Win7): When I updated the bios, it did show as completed but when I restarted the computer, it did not boot. So I removed the CMOS battery for about 5 minutes, put it back in, booted into the bios and reset the time and date. My drive was set up originally for AHCI but after the bios update and removing the CMOS battery, it was showing as RAID. I changed it back to AHCI. Rebooted the computer successfully to Windows. I checked the bios date and it was still the original bios. I am not sure if the updated bios was removed after removing the CMOS battery but the original bios was showing.
You all had me panicked. Mine restarted, thank god
to recovery BIOS Phenix in Pavilion notebook You need:
- FDD Disk (You must do this with Crisi Disk program with Bios.wph to Your laptop)
- Floppy on USB
- turn on notebook with keys Windows and B to start in ZOMBIE MODE.
- Bios.WPH to your laptop You must get from spxxxx.exe file from HP site
- Bios.WPH file You can uncompressed from spxxxx.exe by the 7-ZIP program.

Oryginally spxxxx.exe is packed WinFlash for windows with bios.wph.

originally procedure:
Remove your your battery (or battery and hard disk).

You should force the system to boot from either the FLOPPY, CDROM or a FlashDrive.

Download and unzip B1800 crisis recovery disk and be sure you replace the provided bios (BIOS.WPH) file with your laptop most current bios file (Phoenix only). Note that you should first extract from the BIOS updater exe tool the BIOS ROM, then rename your ROM as BIOS.WPH.

Use crisdisk tool to create a bootable diskette and a bootable floppy with the files phlash.exe, minidos.sys and (your bios file) bios.wph will be created for you

Held Win+B key (other report the key combination being Fn+B)

plug in AC adaptor

Push the power button, with the two other buttons still down.
If the power led start, release the `Fn'and `B' button.
If you're lucky, you'll hear lots of beeps.... Your computer will reset itself and start in Windows!! can take 5 to 10 minutes so be patient.

Powered on, it did some beeping then I saw the light access of my flash drive, when the light stop I released win+b, it did some beeping then the cpu fan quick in (I knew then I was in good shape because it's the sound it make when the bios is flashing) then it stop and more beeping for 30 secs then it powered itself off .. done!

If the booting doesn't succeed, try a different timing on releasing the `Fn' and `B' button.

good luck
Thanks a Million for that piece of advice. Have a quite noisy laptop with Intel i7-3820 processor. Using the Intel Extreme Tuning Utility from them I reduced the Core Current Limit in order to make the CPU run with less power consumption, hence slowing down the cooling fan (kind of 'under clocking' if you will). However, at first attempt I set the core current limit too low so that the laptop didn't even start! Thanks to that trick I could get the laptop to boot up and increase the core current limit to about 80% of the recommended value (135A - no mistake!) and it all working fine again. Thanks again :-)

I tried to fix for over 30 minutes. It ended up that all I had to do on my pavilion m6 was to remove the battery and hard drive at the same time. Then attempted to reboot and it finished flashing bios like it was supposed to do. After it successfully flashed the bios I plugged everything back in and works perfect again! Thanks for everybody's input.
> Thankful techy
Removing the battery and HDD to let it finish the flashing worked for me. Thanks a lot.
I hade same problame on Lenovo z50-75 (win8.1)

But I solved it with OS Boot mode change from UEFI to Legacy mod.
Bios updater changed this mod to uefi with out any reason.
I almost open my laptop just to find the reset button on the bios battery, and then I searching for answer you just need to change the boot mode from UEFI to Legacy.. Thanks for everyone! Lenovo Z50-75
Thanks a ton! This worked for me as well. I have Lenovo Z580.
Hi all!
I have a similar problem. The HP installation recommended me to upgrade the BIOS. I installed the new version. when it rebooted, the BIOS Update finished and the machine reboot. Is in a looping.
In addition, before a reboot, the machine made 8 beeps.

what could I do?

Please help me.
i have go this problame too
but how I find the solution is
1. make a bootable windows on flash disk
2.power off your computer and power on simply laves it .it will start from the bootable flash after it starts shutedown the computer and star again.
3.when it start goto bios set up and chaneg secure boot or legacy boot enabel or desable and save it and exit
4.finally start your computer without the bootable flash .it Will starts

and tell me weather this solution is solved your problam or not pls