No display on acer travelmate P253-E [Solved/Closed]

monna oa likhang 12 Posts Thursday October 14, 2010Registration date January 8, 2016 Last seen - Apr 15, 2014 at 08:03 AM - Latest reply: monna oa likhang 12 Posts Thursday October 14, 2010Registration date January 8, 2016 Last seen
- Jan 8, 2016 at 04:41 AM
hello...can anyone help me out with this, acer travelmate P253-E can't display after power cutoff from the mains supply since there was no battery inside. Actually, the screen power up but it just stays black after pressing the power button, there is nothing displayed, no logo, no "press f2" commands, there is completely nothing!! can anyone tell me how to go about this? thanx in advance for your response.
See more 

12 replies

Best answer
monna oa likhang 12 Posts Thursday October 14, 2010Registration date January 8, 2016 Last seen - Apr 17, 2014 at 01:56 AM
2
Thank you
Oh I meant to say "in this case it can't even pass the bios stage"

Thank you, monna oa likhang 2

Something to say? Add comment

CCM has helped 1887 users this month

jack4rall 6505 Posts Sunday June 6, 2010Registration dateModeratorStatus December 30, 2015 Last seen - Apr 17, 2014 at 07:28 AM
Hello,
in this case it can't even pass the bios stage - Do you mean it got stuck at the acer logo screen ?
BIOS flashing should be done only when you have an idea about it. A wrong BIOS flashing or
flashing done without following the manufacture's instructions can lead to major problems.
First connect the external monitor to your laptop and then switch ON your laptop. Then tap the combination keys.
Good Luck
1
Thank you
How did u flash the bios? I am also facing the same problem.
jack4rall 6505 Posts Sunday June 6, 2010Registration dateModeratorStatus December 30, 2015 Last seen - Apr 15, 2014 at 05:24 PM
0
Thank you
Hello,

Try this 1

1) Remove the AC power adapter --> Remove the battery --> Hold the power

button for 60 seconds --> Connect the AC power adapter then try to switch ON

the laptop and later put the battery back into the laptop.

2) If the problem still exists then click on the below link and follow the instructions

http://ccm.net/faq/9066-display-problem-laptop

Good Luck
monna oa likhang 12 Posts Thursday October 14, 2010Registration date January 8, 2016 Last seen - Apr 15, 2014 at 05:55 PM
0
Thank you
Thanx for a quick reply jack..I actually did that as my frst step..bt it cudnt help...the baclight still stays on..bt nothing displayed..only a black screen..so let me try these instructions in this link u suggested...I will give a feedbck!
monna oa likhang 12 Posts Thursday October 14, 2010Registration date January 8, 2016 Last seen - Apr 15, 2014 at 06:20 PM
0
Thank you
I have just checked the instructions on the link but I did try them before and non of them worked...the ram works perfactely in another computer..cmos battry is stil ok...I took it out for some tyme.then put it back..stil nthin..I thought bios was somehw corrupt and there4 I tried flashing bios and I tnk I got things worse coz now d screen takes some time to light up as compared to before..so I'm not sure whetha the bios is stil ok den and I don't have a similar machine to swap d bios chips...I'm now thinkin of checkin every possible voltage and testin any suspecious component on the motherboard!I'm realy stuck!don't knw what to do!!
jack4rall 6505 Posts Sunday June 6, 2010Registration dateModeratorStatus December 30, 2015 Last seen - Apr 15, 2014 at 08:52 PM
Hello,
Try this 1
Make sure that you have flashed the correct BIOS following the instructions given by your laptop manufacturer.
Have you tried connecting to the external monitor and used the correct combination keys to swap the display to the external monitor ? If you still failed to get the display the problem might be with the motherboard.
Good Luck
monna oa likhang 12 Posts Thursday October 14, 2010Registration date January 8, 2016 Last seen - Apr 17, 2014 at 01:52 AM
0
Thank you
Yes I believ it's a motherboard issue coz I did try external monitor...tried the key combinations which I don't think would help though because I believ they only work when the pc has booted on windows..so in this case it can even pass bios stage..but I wil try finding the exact model nd connect this screen to see if it works perfactly as I ques it does! I actualy download the bios frm the manufactr site..but it was .exe file so I couldn't exract the .bin or .fd files ..so some guy from other forum gave me the link for both modded and original bios...from there I found an exact .bin file for the bios chip in this motherboard from 4shared.com..but nothing worked for me!!
monna oa likhang 12 Posts Thursday October 14, 2010Registration date January 8, 2016 Last seen - Apr 19, 2014 at 05:43 AM
0
Thank you
I mean it couldn't even show logo...but hey..I got everythin under control...I successefully flashed bios nd I got things back to normal!! The problem was a corrupt bios. Thanx for your support jack! :-)...I'm so happy!
Hi I have the same problem too ..i cant find a file to flash my bios do you still have it
tauekhopo 1 Posts Wednesday January 6, 2016Registration date January 6, 2016 Last seen - Jan 6, 2016 at 03:01 AM
mei Bra I have the exactly the problem you had,how can I contact you cos I think we are in the same area or location with respect to the language of our usernames.or just an email address please Bro
monna oa likhang 12 Posts Thursday October 14, 2010Registration date January 8, 2016 Last seen - Jan 8, 2016 at 04:41 AM
I think I am still having the files in my old pc...i will check em when I have time!...y'all can find me on facebook : https://www.facebook.com/lesley.dipholo

Ntate tauekhopo, haha, yes, I believe we in the same area bro! :-) #impressive