PC Powers on, Fans & Hard disk spinning, but no display & beep

[Closed]
Report
Posts
5
Registration date
Sunday June 21, 2015
Status
Member
Last seen
June 22, 2015
-
Posts
3569
Registration date
Friday February 6, 2015
Status
Moderator
Last seen
July 18, 2016
-
I'm not using my pc for months already and so I tried to use it again yesterday. I plugged everything and turn on the PC. It doesn't boot completely so I formatted the hard disk and it boots successfully after the format. I already did windows update and installed everything successfully. After the update it's fine. So I turn it off after using it for a couple of hours. But when I turn it on again after few hours... its not booting, no display, no beep, fans and hard disk working.

I already did clean everything.
Used different ram sticks, cpu fans, power supply, or even processor which is with the same socket and use video card 'cause i guess maybe its just the vga of the board. But none of it works with my old computer. No beep, no display, fans and hard disk working. Those that I used for testing are working in good condition. So I am wondering what's the problem?

1 reply

Posts
3569
Registration date
Friday February 6, 2015
Status
Moderator
Last seen
July 18, 2016
858
First switch off the pc, then remove the RAM sticks, switch on the pc, did you hear any beeps (3 beeps?)

Please inform us when the issue is resolved. Thank you.
4
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month

Posts
5
Registration date
Sunday June 21, 2015
Status
Member
Last seen
June 22, 2015

i also checked if the speaker is not plug-in in the motherboard but it is placed properly.
Posts
3569
Registration date
Friday February 6, 2015
Status
Moderator
Last seen
July 18, 2016
858
How may RAM slots you have? Did you try RAM in different slots if you have?
Because faulty RAM or RAM slots cause no display but i confused that why you did not hear beeps if RAM is faulty?... did you use external graphic card?
Posts
5
Registration date
Sunday June 21, 2015
Status
Member
Last seen
June 22, 2015
>
Posts
3569
Registration date
Friday February 6, 2015
Status
Moderator
Last seen
July 18, 2016

I have 4 ram slots. i tried to insert ram on every slots one by one. still nothing happens. i have no external graphics card
Posts
5
Registration date
Sunday June 21, 2015
Status
Member
Last seen
June 22, 2015

i suspected that it may be just a RAM problem so i borrowed working RAMS from my other computers. But still nothing happens. No beeps
Posts
3569
Registration date
Friday February 6, 2015
Status
Moderator
Last seen
July 18, 2016
858
Did your monitor shows atleast no signal message or not?.. It is(monitor) connected to separate power slot or in your cpu power slot?